您的位置:首页 > 其它

TOJ 3519.Ones and Zeros

2017-07-29 10:07 288 查看
题目链接:http://acm.tju.edu.cn/toj/showp3519.html

3519.   Ones and Zeros
Time Limit: 1.0 Seconds   Memory Limit: 65536K
Total Runs: 702   Accepted Runs: 395

Though numbers are created by human beings, but there are still lots of mysteries about them. For example, for a certain positive integer n and a certain system p such as decimal, hex and so on, does a
positive integer m exist that it is a multiple of n and it only contains 0 and 1 in system p.

 

Input

The first line containing a integer T indicating the number of cases.

Each case has a single line with n and p.(0<= n < 1000000 , 2 <= p < 1000000)

Output

For each case, output "Yes"(m exists) or "No"(no such number) in a single line.

Input Example

Sample Input

2
4 2
3 10

Sample Output

Yes
Yes


hint: 100(2) = 4*1(10), 111(10)=3*37(10);

Source: TJU Team
Selection Contest 2010 (4)

结果是都是Yes,不过证明了半天找不到头绪,就很气~~

#include <stdio.h>
int main(){
int n,p,cas;
scanf("%d",&cas);
while(cas--){
scanf("%d%d",&n,&p);
puts("Yes");
}

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  toj 数论