您的位置:首页 > 其它

Aladdin and the Flying Carpet Light OJ 1341

2017-07-28 21:48 232 查看
题目链接:点我

It's said that Aladdin had to solve seven mysteries before getting the Magical Lamp which summons a powerful Genie. Here we are concerned about the first mystery.

Aladdin was about to enter to a magical cave, led by the evil sorcerer who disguised himself as Aladdin's uncle, found a strange magical flying carpet at the entrance. There were some strange creatures guarding the entrance of the cave. Aladdin could run, but he knew that there was a high chance of getting caught. So, he decided to use the magical flying carpet. The carpet was rectangular shaped, but not square shaped. Aladdin took the carpet and with the help of it he passed the entrance.

Now you are given the area of the carpet and the length of the minimum possible side of the carpet, your task is to find how many types of carpets are possible. For example, the area of the carpet 12, and the minimum possible side of the carpet is 2, then there can be two types of carpets and their sides are: {2, 6} and {3, 4}.


Input

Input starts with an integer T (≤ 4000), denoting the number of test cases.

Each case starts with a line containing two integers: a b (1 ≤ b ≤ a ≤ 1012) where a denotes the area of the carpet and b denotes the minimum possible side of the carpet.


Output

For each case, print the case number and the number of possible carpets.


Sample Input

2

10 2

12 2


Sample Output

Case 1: 1

Case 2: 2


题意:

给你一个数a,要求两个数的乘积恰好为a,并且数的大小最小为b.


思路:

唯一分解定理,本题即是在求a的因数对数,并且每个因子满足大于等于b.那么我们可以用唯一分解定理找出a的所有因子.根据唯一分解定理,每个质因子的幂再加一的乘积,


代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<cmath>
#include<queue>
using namespace std;
const int maxn = 1e6 +1;
bool isprime[maxn];
int prim[maxn/10];
int k;

void prime(){//线性欧拉打素数
memset(isprime,false,sizeof(isprime));
k = 0;
for(int i = 2; i < maxn; ++i){
if(!isprime[i]) prim[++ k] = i;
for(int j = 1; j <= k && i * prim[j] < maxn; ++j){
i
4000
sprime[i * prim[j]] = true;
if( i % prim[j] == 0) break;
}
}
}

int main(){
prime();
int t;
scanf("%d", &t);
int cas = 0;
while( t--){
long long a, b;
scanf("%lld %lld", &a, &b);
if(a < b * b){
printf("Case %d: 0\n", ++cas);
continue;
}
int ans = 1;
long long tmp = a;
for(int j = 1; j <= k && prim[j] <= sqrt(a); ++j){
int cnt = 1;
while( a % prim[j] == 0){
++cnt;
a = a / prim[j];
} ans *= cnt;
}
if (a > 1) ans *= 2;
ans /= 2;
for(int i = 1; i < b; ++i)
if ( tmp % i == 0)//排除掉小于b的点的对数
ans--;
printf("Case %d: %d\n", ++cas, ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: