您的位置:首页 > 编程语言 > C语言/C++

hdu2055 An easy problem(C语言)

2017-07-28 17:55 429 查看
Problem Description

we define f(A) = 1, f(a) = -1, f(B) = 2, f(b) = -2, ... f(Z) = 26, f(z) = -26;

Give you a letter x and a number y , you should output the result of y+f(x).

 

Input

On the first line, contains a number T.then T lines follow, each line is a case.each case contains a letter and a number.

 

Output

for each case, you should the result of y+f(x) on a line.

 

Sample Input

6
R 1
P 2
G 3
r 1
p 2
g 3

 

Sample Output

19
18
10
-17
-14
-4

 

Author

8600

 

Source

校庆杯Warm Up

C语言AC代码

#include<stdio.h>
int main()
{
int n;
scanf("%d",&n);
getchar();
while(n--)
{
char c;
int y;
scanf("%c %d",&c,&y);
getchar();
if(c>='A'&&c<='Z')
printf("%d\n",y+c-'A'+1);
else
printf("%d\n",y-(c-'a'+1));
}
return 0;
}
再上一个牛逼版本的,不是我写的,值得学习!

#include <stdio.h>
int main()
{
int n, a;
char c;
scanf("%d%*c", &n);
while (n-- && scanf("%c%d%*c", &c, &a))
printf("%d\n", a + (c < 97 ? c - 'A' + 1 : 'a' - c - 1));
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: