您的位置:首页 > 其它

HDU 6033 Add More Zero【】

2017-07-28 13:56 453 查看


Add More Zero

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)

Total Submission(s): 1082    Accepted Submission(s): 725


Problem Description

There is a youngster known for amateur propositions concerning several mathematical hard problems.

Nowadays, he is preparing a thought-provoking problem on a specific type of supercomputer which has ability to support calculations of integers between 0 and (2m−1) (inclusive).

As a young man born with ten fingers, he loves the powers of 10 so
much, which results in his eccentricity that he always ranges integers he would like to use from 1to 10k (inclusive).

For the sake of processing, all integers he would use possibly in this interesting problem ought to be as computable as this supercomputer could.

Given the positive integer m,
your task is to determine maximum possible integer k that
is suitable for the specific supercomputer.

 

Input

The input contains multiple test cases. Each test case in one line contains only one positive integer m,
satisfying 1≤m≤105.

 

Output

For each test case, output "Case #x: y"
in one line (without quotes), where x indicates
the case number starting from 1 and y denotes
the answer of corresponding case.

 

Sample Input

1
64

 

Sample Output

Case #1: 0
Case #2: 19

 

Source

2017 Multi-University Training Contest
- Team 1

 

答案就是 \left
\lfloor \log_{10}(2^m - 1) \right \rfloor⌊log​10​​(2​m​​−1)⌋,注意到不存在 10^k
= 2^m10​k​​=2​m​​ ,所以\left
\lfloor \log_{10}(2^m - 1) \right \rfloor = \left \lfloor \log_{10}{2^m} \right \rfloor = \left \lfloor m \log_{10}{2} \right \rfloor⌊log​10​​(2​m​​−1)⌋=⌊log​10​​2​m​​⌋=⌊mlog​10​​2⌋,这样做的时间复杂度是
O(1) 。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
#include<queue>
#include<stack>
#include<vector>
#include<map>
#include<set>
#include<algorithm>
using namespace std;
#define ll long long
#define ms(a,b)  memset(a,b,sizeof(a))
#define maxn 510
const int M=1e6+10;
const int inf=0x3f3f3f3f;
const int mod=1e9+7;
const double eps=1e-10;
ll n,m;

int main()
{
int cas=1;
while(~scanf("%d",&m))
{
int ans=m*(log10(2.0));
printf("Case #%d: %d\n",cas++,ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: