您的位置:首页 > 其它

POJ 2676 Sudoku 深搜

2017-07-28 11:55 363 查看
Sudoku is a very simple task. A square table with 9 rows and 9 columns is divided to 9 smaller squares 3x3 as shown on the Figure. In some of the cells are written decimal digits from 1 to 9. The other cells are empty. The goal
is to fill the empty cells with decimal digits from 1 to 9, one digit per cell, in such way that in each row, in each column and in each marked 3x3 subsquare, all the digits from 1 to 9 to appear. Write a program to solve a given Sudoku-task. 



Input
The input data will start with the number of the test cases. For each test case, 9 lines follow, corresponding to the rows of the table. On each line a string of exactly 9 decimal digits is given, corresponding to the cells in
this line. If a cell is empty it is represented by 0.

Output
For each test case your program should print the solution in the same format as the input data. The empty cells have to be filled according to the rules. If solutions is not unique, then the program may print any one of them.

Sample Input
1
103000509
002109400
000704000
300502006
060000050
700803004
000401000
009205800
804000107


Sample Output
143628579
572139468
986754231
391542786
468917352
725863914
237481695
619275843
854396127

深度优先搜索,选好标记就不会超时,用三个二维数组来标记行,列,区

#include<cstdio>
#include<vector>
#include<cstring>
using namespace std;
char mapp[10][10];
struct Node
{
int x, y, b;
int val;
};
vector<Node> a;
bool row[10][10], clu[10][10], blo[10][10];//标记数组
bool f;
void dfs(int cur)
{
if(f)
return;
if(cur==a.size())
{
f = true;
return;
}
int xt, yt, bt;
xt = a[cur].x;
yt = a[cur].y;
bt = a[cur].b;
for(int i=1;i<=9;i++)
{
if(!row[xt][i]&&!clu[yt][i]&&!blo[bt][i])
{
a[cur].val = i;
row[xt][i] = clu[yt][i] = blo[bt][i] = true;
dfs(cur+1);
if(f)
return;
a[cur].val = 0;
row[xt][i] = clu[yt][i] = blo[bt][i] = false;
}
}
}
int main()
{
int t, num, block;
Node tm;
scanf("%d", &t);
while(t--)
{
memset(row, false, sizeof(row));
memset(clu, false, sizeof(clu));
memset(blo, false, sizeof(blo));
a.clear();
for(int i=1;i<=9;i++)
for(int j=1;j<=9;j++)
{
scanf(" %c", &mapp[i][j]);
num = mapp[i][j] - '0';
row[i][num] = true;
clu[j][num] = true;
if(i<=3)
{
if(j<=3)
block = 1;
else if(j<=6)
block = 2;
else
block = 3;
}
else if(i<=6)
{
if(j<=3)
block = 4;
else if(j<=6)
block = 5;
else
block = 6;
}
else
{
if(j<=3)
block = 7;
else if(j<=6)
block = 8;
else
block = 9;
}
blo[block][num] = true;
if(num==0)
{
tm.x = i;
tm.y = j;
tm.b = block;
a.push_back(tm);
}
}
f = false;
dfs(0);
for(int i=0;i<a.size();i++)
mapp[a[i].x][a[i].y] = '0' + a[i].val;
for(int i=1;i<=9;i++)
{
for(int j=1;j<=9;j++)
printf("%c", mapp[i][j]);
printf("\n");
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: