您的位置:首页 > 其它

HDU5143 NPY and arithmetic progression【暴力】

2017-07-28 09:19 411 查看

NPY and arithmetic progression

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1505    Accepted Submission(s): 465

[align=left]Problem Description[/align]NPY is learning arithmetic progression in his math class. In mathematics, an arithmetic progression (AP) is a sequence of numbers such that the difference between the consecutive terms is constant.(from wikipedia)
He thinks it's easy to understand,and he found a challenging problem from his talented math teacher:
You're given four integers, a1,a2,a3,a4, which are the numbers of 1,2,3,4 you have.Can you divide these numbers into some Arithmetic Progressions,whose lengths are equal to or greater than 3?(i.e.The number of AP can be one)
Attention: You must use every number exactly once.
Can you solve this problem?
InputThe first line contains a integer T — the number of test cases (1≤T≤100000).
The next T lines,each contains 4 integers a1,a2,a3,a4(0≤a1,a2,a3,a4≤109).OutputFor each test case,print "Yes"(without quotes) if the numbers can be divided properly,otherwise print "No"(without quotes).Sample Input
3
1 2 2 1
1 0 0 0
3 0 0 0Sample Output
Yes
No
Yes
HintIn the first case,the numbers can be divided into {1,2,3} and {2,3,4}.
In the second case,the numbers can't be divided properly.
In the third case,the numbers can be divided into {1,1,1}. SourceBestCoder Round #22
问题链接HDU5143 NPY and arithmetic progression
问题简述:(略)
问题分析:(略)

程序说明:占个位置。
题记:(略)

参考链接:(略)

AC的C++语言程序如下:/* HDU5143 NPY and arithmetic progression */

#include <iostream>
#include <stdio.h>

using namespace std;

const int N = 4;
int a
;

bool check(int i, int j, int k, int n)
{
int v[4] = {a[0] - i - k, a[1] - i - j - k, a[2] - i - j - k, a[3] - j - k};
for(int i=0; i<n; i++)
if(v[i] != 0 && v[i] < 3)
return false;
return true;
}

bool judge(int n)
{
for(int i=0; i<n-1; i++)
for(int j=0; j<n-1; j++)
for(int k=0; k<n-1; k++)
if(check(i, j, k, n))
return true;
return false;
}

int main()
{
int t;

scanf("%d", &t);
while(t--) {
for(int i=0; i<N; i++)
scanf("%d", &a[i]);

printf("%s\n", judge(N) ? "Yes" : "No");
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: