您的位置:首页 > 其它

UVA - 12034 Race

2017-07-28 08:36 423 查看

Race

Disky and Sooma, two of the biggest mega minds of Bangladesh went to a far country. They ate, coded and wandered around, even in their holidays. They passed several months in this way. But everything has an end. A holy person, Munsiji came into their life. Munsiji took them to derby (horse racing). Munsiji enjoyed the race, but as usual Disky and Sooma did their as usual task instead of passing some romantic moments. They were thinking- in how many ways a race can finish! Who knows, maybe this is their romance! In a race there are n horses. You have to output the number of ways the race can finish. Note that, more than one horse may get the same position. For example, 2 horses can finish in 3 ways.

1. Both first

2. horse1 first and horse2 second

3. horse2 first and horse1 second

Input Input starts with an integer T (≤ 1000), denoting the number of test cases. Each case starts with a line containing an integer n (1 ≤ n ≤ 1000).

Output

For each case, print the case number and the number of ways the race can finish. The result can be very large, print the result modulo 10056.

Sample Input

3 1 2 3

Sample Output

Case 1: 1 Case 2: 3 Case 3: 13

递推方程:d[i][j] = d[i-1][j]*j + d[i-1][j-1]*j; 其中i为马的数量,j为结果排名的组数,答案只要将d
[1]~d

累加即可


#include <iostream>
#include <cstdio>

using namespace std;

const int  maxn = 1e3 + 10;

int n, t;
int d[maxn][maxn];

int main()
{
d[1][1] = d[2][1] = 1;
d[2][2] = 2;
for(int i = 3; i <= 1000; i++)
{
for(int j = 1; j <= i; j++)
{
d[i][j] = d[i-1][j]*j + d[i-1][j-1]*j;
d[i][j] %= 10056;
}
}
while(cin >> t)
{
for(int i = 1; i <= t; i++)
{
cin >> n;
int ans = 0;
for(int j = 1; j <= n; j++)
{
ans += d
[j];
ans %= 10056;
}
printf("Case %d: %d\n", i, ans);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: