您的位置:首页 > 编程语言 > Go语言

Regular polygon 数学几何

2017-07-27 22:13 253 查看

Description

On a two-dimensional plane, give you n integer points. Your task is to figure out how many different regular polygon these points can make.

Input

The input file consists of several test cases. Each case the first line is a numbers N (N <= 500). The next N lines ,each line contain two number Xi and Yi(-100 <= xi,yi <= 100), means the points’ position.(the data assures no two points share the same position.)

Output

For each case, output a number means how many different regular polygon these points can make.

Sample Input

4

0 0

0 1

1 0

1 1

6

0 0

0 1

1 0

1 1

2 0

2 1

Sample Output

1

2

Hint

题意

题解:

只能构成正方形 暴力枚举任意两个点 判断即可

AC代码

#include <cstdio>
#include <iostream>
#include <queue>
#include <map>
#include <vector>
#include <cmath>
#include <set>
#include <cstring>
#include <algorithm>
using namespace std;
typedef long long LL;
typedef pair<int ,int> P;
const int N = 500;
int vis

;
struct node{
int x,y;
}p
;
int main(){
int n;
while (scanf("%d",&n)!=EOF){
memset(vis,0,sizeof(vis));
for (int i = 0; i < n; ++i){
scanf("%d%d",&p[i].x,&p[i].y);
p[i].x+=200;
p[i].y+=200;
vis[p[i].x][p[i].y] = 1;
}
int ans = 0;
for (int i = 0; i < n; ++i){
for (int j = i+1; j < n; ++j){
node a = p[i];node b = p[j];
int dx = a.x-b.x;
int dy = a.y-b.y;
if (a.x+dy>=0&&a.y-dx>=0&&b.y-dx>=0&&b.x+dy>=0&&vis[a.x+dy][a.y-dx]&&vis[b.x+dy][b.y-dx]){
ans++;
}
if (a.x-dy>=0&&a.y+dx>=0&&b.y+dx>=0&&b.x-dy>=0&&vis[a.x-dy][a.y+dx]&&vis[b.x-dy][b.y+dx]){
ans++;
}
}
}
printf("%d\n",ans/4);

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: