您的位置:首页 > 其它

HDU 6045 Is Derek lying?

2017-07-27 20:18 267 查看

Is Derek lying?

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)


[align=left]Problem Description[/align]
Derek
and Alfia
are good friends.Derek
is Chinese,and Alfia
is Austrian.This summer holiday,they both participate in the summer camp of Borussia Dortmund.During the summer camp,there will be fan tests at intervals.The test consists of
N
choice questions and each question is followed by th
11f84
ree choices marked “A”
“B”
and “C”.Each
question has only one correct answer and each question is worth
1
point.It means that if your answer for this question is right,you can get
1
point.The total score of a person is the sum of marks for all questions.When the test is over,the computer will tell
Derek
the total score of him and Alfia.Then
Alfia
will ask Derek
the total score of her and he will tell her: “My total score is
X,your
total score is Y.”But
Derek
is naughty,sometimes he may lie to her. Here give you the answer that
Derek
and Alfia
made,you should judge whether Derek
is lying.If there exists a set of standard answer satisfy the total score that
Derek
said,you can consider he is not lying,otherwise he is lying.
 

[align=left]Input[/align]
The first line consists of an integer
T,represents
the number of test cases.

For each test case,there will be three lines.

The first line consists of three integers N,X,Y,the
meaning is mentioned above.

The second line consists of N
characters,each character is “A”
“B”
or “C”,which
represents the answer of Derek
for each question.

The third line consists of N
characters,the same form as the second line,which represents the answer of
Alfia
for each question.

Data Range:1≤N≤80000,0≤X,Y≤N,∑Ti=1N≤300000
 

[align=left]Output[/align]
For each test case,the output will be only a line.

Please print “Lying”
if you can make sure that Derek
is lying,otherwise please print “Not lying”.
 

[align=left]Sample Input[/align]

2
3 1 3
AAA
ABC
5 5 0
ABCBC
ACBCB

 

[align=left]Sample Output[/align]

Not lying
Lying

 
[align=left]
[/align]
这道题没什么好说的,很水的一道题。不过没能第一时间想到正确的限制条件还是个很大的失误。
通过自己模拟a+b>n和a+b=n的数据可以更好的理解限制条件。

AC代码:

#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdio>
#include<cmath>
using namespace std;
char a[88888];
char b[88888];
int main()
{
int T;
int n;
int aa,bb;
cin>>T;
while(T--)
{
scanf("%d%d%d",&n,&aa,&bb);
cin>>a>>b;
int ans=0;
int res=0;
for(int i=0;i<n;i++)
{
if(a[i]==b[i])
res++;
}
ans=fabs(aa-bb);
if(res>=aa+bb-n&&res<=n-ans)
cout<<"Not lying"<<endl;
else
cout<<"Lying"<<endl;
}
return 0;
}


 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: