您的位置:首页 > 大数据 > 人工智能

2017 Multi-University Training Contest - Team 2:1001&hdu6045、 Is Derek lying?

2017-07-27 18:04 417 查看

题目:

Is Derek lying?

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 0    Accepted Submission(s): 0


[align=left]Problem Description[/align]
Derek
and Alfia
are good friends.Derek
is Chinese,and Alfia
is Austrian.This summer holiday,they both participate in the summer camp of Borussia Dortmund.During the summer camp,there will be fan tests at intervals.The test consists ofN
choice questions and each question is followed by three choices marked “A”
“B”
and “C”.Each
question has only one correct answer and each question is worth
1
point.It means that if your answer for this question is right,you can get
1
point.The total score of a person is the sum of marks for all questions.When the test is over,the computer will tellDerek
the total score of him and Alfia.ThenAlfia
will ask Derek
the total score of her and he will tell her: “My total score is
X,your
total score is Y.”ButDerek
is naughty,sometimes he may lie to her. Here give you the answer that
Derek
and Alfia
made,you should judge whether Derek
is lying.If there exists a set of standard answer satisfy the total score that
Derek
said,you can consider he is not lying,otherwise he is lying.
 

[align=left]Input[/align]
The first line consists of an integerT,represents
the number of test cases.

For each test case,there will be three lines.

The first line consists of three integers N,X,Y,the
meaning is mentioned above.

The second line consists of N
characters,each character is “A”
“B”
or “C”,which
represents the answer of Derek
for each question.

The third line consists of N
characters,the same form as the second line,which represents the answer of
Alfia
for each question.

Data Range:1≤N≤80000,0≤X,Y≤N,∑Ti=1N≤300000
 

[align=left]Output[/align]
For each test case,the output will be only a line.

Please print “Lying”
if you can make sure that Derek
is lying,otherwise please print “Not lying”.
 

[align=left]Sample Input[/align]

2
3 1 3
AAA
ABC
5 5 0
ABCBC
ACBCB

 

[align=left]Sample Output[/align]

Not lying
Lying

题意:有n道题目,每道题目3个选择A、B、C,答对得一分。给你两个人的分数X和Y,判断是否有标准答案满足X和Y

思路:找到两个人不同的选项,如果不同的选项数目大于等于他们分数差距而且两个人分数和减去相同选项的数目小鱼等于n,说明没有说谎。

CODE:

#include<bits/stdc++.h>
using namespace std;
char a[80005],b[80005];
int main()
{
int t,n,x,y;
scanf("%d",&t);
while(t--){
scanf("%d%d%d%s%s",&n,&x,&y,a,b);
int num=0;
for(int i=0;i<n;i++) if(a[i]!=b[i]) num++;
if(abs(x-y)<=num&&x+y-(n-num)<=n) puts("Not lying");
else puts("Lying");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  思维题
相关文章推荐