您的位置:首页 > 大数据 > 人工智能

hdu 6045 Is Derek lying?(2017 Multi-University Training Contest - Team 2)

2017-07-27 17:39 573 查看

Is Derek lying?

Problem Description

Derek and Alfia are good friends.Derek is Chinese,and Alfia is Austrian.This summer holiday,they both participate in the summer camp of Borussia Dortmund.During the summer camp,there will be fan tests at intervals.The test consists of N choice questions and each question is followed by three choices marked “A” “B” and “C”.Each question has only one correct answer and each question is worth 1 point.It means that if your answer for this question is right,you can get 1 point.The total score of a person is the sum of marks for all questions.When the test is over,the computer will tell Derek the total score of him and Alfia.Then Alfia will ask Derek the total score of her and he will tell her: “My total score is X,your total score is Y.”But Derek is naughty,sometimes he may lie to her. Here give you the answer that Derek and Alfia made,you should judge whether Derek is lying.If there exists a set of standard answer satisfy the total score that Derek said,you can consider he is not lying,otherwise he is lying.

Input

The first line consists of an integer T,represents the number of test cases.

For each test case,there will be three lines.

The first line consists of three integers N,X,Y,the meaning is mentioned above.

The second line consists of N characters,each character is “A” “B” or “C”,which represents the answer of Derek for each question.

The third line consists of N characters,the same form as the second line,which represents the answer of Alfia for each question.

Data Range:1≤N≤80000,0≤X,Y≤N,∑Ti=1N≤300000

Output

For each test case,the output will be only a line.

Please print “Lying” if you can make sure that Derek is lying,otherwise please print “Not lying”.

Sample Input

2

3 1 3

AAA

ABC

5 5 0

ABCBC

ACBCB

Sample Output

Not lying

Lying

ps:没什么技巧,细细分析就行

代码:

#include<stdio.h>
#include<string.h>
#include<queue>
#include<algorithm>
using namespace std;

typedef long long LL;
const int maxn=100000+10;
char s1[maxn],s2[maxn];

int main()
{
int t,n,x,y;
scanf("%d",&t);
while(t--)
{
scanf("%d%d%d",&n,&x,&y);
scanf("%s %s",s1,s2);
int tot=0;//相匹配的长度
for(int i=0; i<n; ++i)
{
if(s1[i]==s2[i])
++tot;
}
if(x>=tot&&y>=tot)
{
x-=tot;
y-=tot;
n-=tot;
if(x+y>n)
printf("Lying\n");
else
printf("Not lying\n");
}
else if(x<tot&&y>=tot)
{
tot-=x;
y-=x;
n-=x;
if(y>n-tot)
printf("Lying\n");
else
printf("Not lying\n");
}
else if(x>=tot&&y<tot)
{
tot-=y;
x-=y;
n-=y;
if(x>n-tot)
printf("Lying\n");
else
printf("Not lying\n");
}
else
{
int num=abs(x-y);
if(n-tot<num)
printf("Lying\n");
else
printf("Not lying\n");
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: 
相关文章推荐