您的位置:首页 > 其它

17 多校 - 2 - 1001 - Is Derek lying? (HDU - 6045)

2017-07-27 17:31 435 查看


Is Derek lying?

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 22    Accepted Submission(s): 15


Problem Description

Derek and Alfia are
good friends.Derek is
Chinese,and Alfia is
Austrian.This summer holiday,they both participate in the summer camp of Borussia Dortmund.During the summer camp,there will be fan tests at intervals.The test consists of N choice
questions and each question is followed by three choices marked “A”
“B”
and “C”.Each
question has only one correct answer and each question is worth 1 point.It
means that if your answer for this question is right,you can get 1 point.The
total score of a person is the sum of marks for all questions.When the test is over,the computer will tell Derek the
total score of him and Alfia.Then Alfia will
ask Derek the
total score of her and he will tell her: “My total score is X,your
total score is Y.”But Derek is
naughty,sometimes he may lie to her. Here give you the answer that Derek and Alfia made,you
should judge whether Derek is
lying.If there exists a set of standard answer satisfy the total score that Derek said,you
can consider he is not lying,otherwise he is lying.

 

Input

The first line consists of an integer T,represents
the number of test cases.

For each test case,there will be three lines.

The first line consists of three integers N,X,Y,the
meaning is mentioned above.

The second line consists of N characters,each
character is “A”
“B”
or “C”,which
represents the answer of Derek for
each question.

The third line consists of N characters,the
same form as the second line,which represents the answer of Alfia for
each question.

Data Range:1≤N≤80000,0≤X,Y≤N,∑Ti=1N≤300000

 

Output

For each test case,the output will be only a line.

Please print “Lying”
if you can make sure that Derek is
lying,otherwise please print “Not lying”.

 

Sample Input

2
3 1 3
AAA
ABC
5 5 0
ABCBC
ACBCB

 

Sample Output

Not lying
Lying

 

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=6045

题意:给出两个人的选项和他们所得的分数,判断是否有人撒谎。

记两人答案相同的题目个数为A,答案不同的个数为B,题目总数为N,两人分别所得分数为X,Y,可以得到 X+Y > N + A 时一定有人撒谎了,因为答案不同的只能有其中一个人对,所以最大的分数和就是N+A。当一题中两人选项不同时有三种情况,一种是第一人对,还有是第二人对,或两人均错,所以两人的分差若大于B则其中有人说了假话,即abs( X+Y ) > B 时有人撒谎。

#include<iostream>
#include<string.h>
#include<stdio.h>
using namespace std;
int t,n,x,y,same;
char s1[80100],s2[80100];
int main()
{
scanf("%d",&t);
while(t--)
{
scanf("%d%d%d",&n,&x,&y);
scanf("%s%s",s1,s2);
same = 0;
for(int i=0;i<n;i++)
{
if(s1[i]==s2[i])
same ++;
}
if(same+n>=x+y&&abs(x-y)<=n-same)
printf("Not lying\n");
else
printf("Lying\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: