您的位置:首页 > 其它

2017杭电多校联赛第二场-Is Derek lying?(hdu6054)

2017-07-27 17:29 525 查看


Is Derek lying?

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 0    Accepted Submission(s): 0


Problem Description

Derek and Alfia are
good friends.Derek is
Chinese,and Alfia is
Austrian.This summer holiday,they both participate in the summer camp of Borussia Dortmund.During the summer camp,there will be fan tests at intervals.The test consists of N choice
questions and each question is followed by three choices marked “A”
“B”
and “C”.Each
question has only one correct answer and each question is worth 1 point.It
means that if your answer for this question is right,you can get 1point.The
total score of a person is the sum of marks for all questions.When the test is over,the computer will tell Derek the
total score of him and Alfia.Then Alfiawill
ask Derek the
total score of her and he will tell her: “My total score is X,your
total score is Y.”But Derek is
naughty,sometimes he may lie to her. Here give you the answer that Derek and Alfia made,you
should judge whether Derek is
lying.If there exists a set of standard answer satisfy the total score that Derek said,you
can consider he is not lying,otherwise he is lying.

 

Input

The first line consists of an integer T,represents
the number of test cases.

For each test case,there will be three lines.

The first line consists of three integers N,X,Y,the
meaning is mentioned above.

The second line consists of N characters,each
character is “A”
“B”
or “C”,which
represents the answer of Derek for
each question.

The third line consists of N characters,the
same form as the second line,which represents the answer of Alfia for
each question.

Data Range:1≤N≤80000,0≤X,Y≤N,∑Ti=1N≤300000

 

Output

For each test case,the output will be only a line.

Please print “Lying”
if you can make sure that Derek is
lying,otherwise please print “Not lying”.

 

Sample Input

2
3 1 3
AAA
ABC
5 5 0
ABCBC
ACBCB

 

Sample Output

Not lying
Lying
题目大意:给你两个人的分数和两个人选择的答案,询问这个答案和分数是否能成立,即判断有没有说谎。
解题思路:由两个人给出的题目答案可以知晓,两个人有的题选择的答案相同,有的题目选择的答案不同,所以我们可以先得到相同的数目和不相同的数目,我们可以知晓这些数目之间一定会满足这些关系。1.两个人的分数之和一定不会大于题目数量加上两个人相同答案的数量。2.两个人的分数之差一定会小于等于答案不相同的题目数量,因为只有可能分数差在答案不同的地方。这两个关系大家想一下就会知道了,知道了这两个关系之后代码就很好写了。
ac代码:
#include <cstdio>
#include <iostream>
#include <cmath>
using namespace std;
#define maxn 800002
char s1[maxn],s2[maxn];
int main()
{
int T, n, x, y, a, b,i;
scanf("%d", &T);
while(T--)
{
a=b=0;
scanf("%d%d%d", &n, &x, &y);
getchar();
gets(s1);
gets(s2);
for(i = 0; i<n;i++)
{
if(s1[i]==s2[i]) a++;
else b++;
}
if(abs(x-y)>b)printf("Lying\n");
else if(x+y>n+a) printf("Lying\n");
else printf("Not lying\n");
}
return 0;
}

题目网址:点击打开链接http://acm.hdu.edu.cn/showproblem.php?pid=6045
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: