您的位置:首页 > 其它

POJ 1012 Joseph

2017-07-27 10:34 399 查看
The Joseph's problem is notoriously known. For those who are not familiar with the original problem: from among n people, numbered 1, 2, . . ., n, standing in circle every mth is going to be executed and only the life of the last
remaining person will be saved. Joseph was smart enough to choose the position of the last remaining person, thus saving his life to give us the message about the incident. For example when n = 6 and m = 5 then the people will be executed in the order 5, 4,
6, 2, 3 and 1 will be saved. 

Suppose that there are k good guys and k bad guys. In the circle the first k are good guys and the last k bad guys. You have to determine such minimal m that all the bad guys will be executed before the first good guy. 

Input
The input file consists of separate lines containing k. The last line in the input file contains 0. You can suppose that 0 < k < 14.

Output
The output file will consist of separate lines containing m corresponding to k in the input file.

Sample Input
3
4
0


Sample Output
5
30

打表

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int res[15];
void Init(){
int sum;
for(int k=1;k<14;k++)
for(int m=k+1;;m++){
sum=k*2;
int flag=0;
for(int j=m;;j+=m-1){
j=j%sum?j%sum:sum;
if(j<=k)
break;
sum--;
if(sum==k){
flag=1;
break;
}
}
if(flag){
res[k]=m;
break;
}
}
}

int main(){
Init();
int k;
while(~scanf("%d",&k) && k){
printf("%d\n",res[k]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: