您的位置:首页 > 大数据 > 人工智能

2017 Multi-University Training Contest - Team 1:KazaQ's Socks(hdu 6043)

2017-07-27 10:18 447 查看


KazaQ's Socks

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)

Total Submission(s): 784    Accepted Submission(s): 489

Problem Description

KazaQ wears socks everyday.

At the beginning, he has n pairs
of socks numbered from 1 to n in
his closets. 

Every morning, he puts on a pair of socks which has the smallest number in the closets. 

Every evening, he puts this pair of socks in the basket. If there are n−1 pairs
of socks in the basket now, lazy KazaQ has to wash them. These socks will be put in the closets again in tomorrow evening.

KazaQ would like to know which pair of socks he should wear on the k-th
day.

 

Input

The input consists of multiple test cases. (about 2000)

For each case, there is a line contains two numbers n,k (2≤n≤109,1≤k≤1018).

 

Output

For each test case, output "Case #x: y"
in one line (without quotes), where x indicates
the case number starting from 1 and y denotes
the answer of corresponding case.

 

Sample Input

3 7
3 6
4 9

 

Sample Output

Case #1: 3
Case #2: 1
Case #3: 2

 

Source

2017 Multi-University Training Contest - Team 1

//题意:总共有n双袜子,每天换一双,如果有n-1双袜子穿了没洗,就把它洗了,洗完第二天晚上就已经是干净可以穿了的。每次穿是穿干净的袜子里编号最小的那双袜子。问第k天穿的是哪双袜子。

//思路:这题就是一道简单的找规律:前1-n天肯定是分别穿1-n的袜子(因为一开始所有袜子都是干净的),n-1天把1-(n-1)袜子洗了,第n+1天1 - (n-1)的袜子是干净的,第n双袜子是脏的,所以接下来n-1天分别穿第1-(n-1)双袜子,然后是1-(n-2)和第n双袜子是干净的,第n-1双袜子是脏的,所以接下来n-1天分别每天穿这n-1双袜子,然后又变成第1
- (n-1)的袜子是干净的,第n双袜子是脏的,循环了。

#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <string>
#include <algorithm>
using namespace std;

int n;
long long k;

int main()
{
int Case = 1;
while (scanf("%d%lld", &n, &k) != EOF)
{
printf("Case #%d: ", Case++);
if (k <= n)
{
printf("%lld\n", k);
continue;
}
k = k - n;
k = k % (2 * n - 2);
if (k == 0)
{
printf("%d\n", n);
continue;
}
if (k <= n - 1)
{
printf("%lld\n", k);
continue;
}
k = k - (n - 1);
if (k <= n - 2)
{
printf("%lld\n", k);
continue;
}
else
printf("%d\n", n);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: 
相关文章推荐