您的位置:首页 > 其它

POJ1265 Area (Pick定理,多边形面积,计算几何)

2017-07-27 08:43 543 查看


                                       Area  POJ - 1265



Being well known for its highly innovative products, Merck would definitely be a good target for industrial espionage. To protect its brand-new research and development facility the company has installed the latest system of surveillance
robots patrolling the area. These robots move along the walls of the facility and report suspicious observations to the central security office. The only flaw in the system a competitor抯 agent could find is the fact that the robots radio their movements unencrypted.
Not being able to find out more, the agent wants to use that information to calculate the exact size of the area occupied by the new facility. It is public knowledge that all the corners of the building are situated on a rectangular grid and that only straight
walls are used. Figure 1 shows the course of a robot around an example area. 


 

Figure 1: Example area. 

You are hired to write a program that calculates the area occupied by the new facility from the movements of a robot along its walls. You can assume that this area is a polygon with corners on a rectangular grid. However, your boss insists that you use a formula
he is so proud to have found somewhere. The formula relates the number I of grid points inside the polygon, the number E of grid points on the edges, and the total area A of the polygon. Unfortunately, you have lost the sheet on which he had written down that
simple formula for you, so your first task is to find the formula yourself. 

Input
The first line contains the number of scenarios. 

For each scenario, you are given the number m, 3 <= m < 100, of movements of the robot in the first line. The following m lines contain pairs 揹x dy�of integers, separated by a single blank, satisfying .-100 <= dx, dy <= 100 and (dx, dy) != (0, 0). Such a pair
means that the robot moves on to a grid point dx units to the right and dy units upwards on the grid (with respect to the current position). You can assume that the curve along which the robot moves is closed and that it does not intersect or even touch itself
except for the start and end points. The robot moves anti-clockwise around the building, so the area to be calculated lies to the left of the curve. It is known in advance that the whole polygon would fit into a square on the grid with a side length of 100
units. 

Output
The output for every scenario begins with a line containing 揝cenario #i:� where i is the number of the scenario starting at 1. Then print a single line containing I, E, and A, the area
4000
A rounded to one digit after the decimal point.
Separate the three numbers by two single blanks. Terminate the output for the scenario with a blank line.

Sample Input
2
4
1 0
0 1
-1 0
0 -1
7
5 0
1 3
-2 2
-1 0
0 -3
-3 1
0 -3


Sample Output
Scenario #1:
0 4 1.0

Scenario #2:
12 16 19.0


不知道为什么这道题有乱码,我一开始以为是别人复制题目的时候出错了,结果上了POJ才发现原来官方题目就有一些乱码Orz,这道题的题意就是告诉你机器人行走的路径,该路径一定会形成一个多边形,求这个多边形边上的在网格上的点的个数,内部在网格上的点的个数和面积。而pick定理就是关于这三个变量的一个公式。

Pick定理:一个计算点阵中顶点在格点上的多边形面积公式:S=a+b/2-1,其中a表示多边形内部的点数,b表示多边形边界上的点数,s表示多边形的面积。

1,多边形的面积等于按顺序求相邻两个点与原点组成的向量的叉积和。

   


2,多边形边界上的点数:

      两顶点连线构成边界,两顶点连线中(边界)所经过的点数为两顶点分别各自横纵坐标的差的最大公约数。gcd(dx,dy)。

3,多边形内部的点数:

     这时候我们因为可以求出前两个变量,所以第三个变量直接用pick定理求。

     inside(多边形内部的点) =  area(多边形面积)+1 -  boundary(多边形边界上的点)/2;

所以AC代码如下

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <vector>
#include <queue>
#include <map>
#include <algorithm>
#include <set>
#include <functional>
using namespace std;
typedef long long LL;
typedef unsigned long long ULL;
const int INF = 1e9 + 5;
const int MAXN = 50007;
const int MOD = 1000000007;
const double eps = 1e-8;
const double PI = acos(-1.0);

int gcd(int a, int b)
{
return b == 0 ? a : gcd(b, a%b);
}

struct point
{
int x;
int y;
};

point p[1005];

int main()
{
int N;
int T;
int x, y;
int S;
int a, b;
scanf("%d", &T);
for (int CASE = 1; CASE <= T; CASE++)
{
scanf("%d", &N);
b = 0;
a = 0;
S = 0;
memset(p, 0, sizeof(p));
for (int i = 1; i <= N; i++)
{
scanf("%d%d", &x, &y);
p[i].x = p[i - 1].x + x;
p[i].y = p[i - 1].y + y;
b += gcd(abs(x), abs(y));
S += (p[i].y*p[i - 1].x - p[i].x*p[i - 1].y);
}
a = S/2 + 1 - b / 2;
printf("Scenario #%d:\n", CASE);
printf("%d %d %.1lf\n\n", a, b, double(S)/2);
}
}
注意!一定要用C++提交,G++不知道为什么用memset初始化结构体的时候会出问题。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: