您的位置:首页 > 其它

POJ3187 Backward Digit Sums【全排列】

2017-07-27 08:36 501 查看
Backward Digit Sums

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7633 Accepted: 4397
Description
FJ and his cows enjoy playing a mental game. They write down the numbers from 1 to N (1 <= N <= 10) in a certain order and then sum adjacent numbers to produce a new list with one fewer number. They repeat this until only
a single number is left. For example, one instance of the game (when N=4) might go like this: 

3   1   2   4

4   3   6

7   9

16

Behind FJ's back, the cows have started playing a more difficult game, in which they try to determine the starting sequence from only the final total and the number N. Unfortunately, the game is a bit above FJ's mental arithmetic capabilities. 

Write a program to help FJ play the game and keep up with the cows.
Input
Line 1: Two space-separated integers: N and the final sum.
Output
Line 1: An ordering of the integers 1..N that leads to the given sum. If there are multiple solutions, choose the one that is lexicographically least, i.e., that puts smaller numbers first.
Sample Input
4 16

Sample Output
3 1 2 4

Hint
Explanation of the sample: 

There are other possible sequences, such as 3 2 1 4, but 3 1 2 4 is the lexicographically smallest.
Source
USACO 2006 February Gold & Silver

问题链接POJ3187 Backward Digit Sums

问题简述:参见上文。

问题分析:计算规模比较小,用全排列和暴力解决问题。三角形的计算直接模拟即可,关键是递推计算公式要正确。

程序说明:(略)

题记:(略)

参考链接:(略)

AC的C++语言程序如下:

/* POJ3187 Backward Digit Sums */

#include <iostream>
#include <algorithm>
#include <stdio.h>

using namespace std;

const int N = 20;
int a
, grid

;

bool check(int n, int sum)
{
for(int i=0; i<n; i++)
grid[0][i] = a[i];
for(int i=1; i<n; i++)
for(int j=0; j<n-i; j++)
grid[i][j] = grid[i - 1][j] + grid[i - 1][j + 1];
return grid[n - 1][0] == sum;
}

int main()
{
int n, sum;

while(scanf("%d%d", &n, &sum) != EOF) {
for(int i=0; i<n; i++)
a[i] = i + 1;

do {
if(check(n, sum)) {
for(int i=0; i<n; i++) {
if(i != 0)
printf(" ");
printf("%d", a[i]);
}
printf("\n");
break;
}
} while(next_permutation(a, a + n));
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: