您的位置:首页 > 其它

文章标题 HDU 2122: Ice_cream’s world III (最小生成树+kruskal)

2017-07-27 08:29 543 查看

Ice_cream’s world III

ice_cream’s world becomes stronger and stronger; every road is built as undirected. The queen enjoys traveling around her world; the queen’s requirement is like II problem, beautifies the roads, by which there are some ways from every city to the capital. The project’s cost should be as less as better.

Input

Every case have two integers N and M (N<=1000, M<=10000) meaning N cities and M roads, the cities numbered 0…N-1, following N lines, each line contain three integers S, T and C, meaning S connected with T have a road will cost C.

Output

If Wiskey can’t satisfy the queen’s requirement, you must be output “impossible”, otherwise, print the minimum cost in this project. After every case print one blank.

Sample Input

2 1

0 1 10

4 0

Sample Output

10

impossible

题意:就是裸的最小生成树

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <queue>
#include <set>
#include <map>
#include <algorithm>
#include <math.h>
#include <vector>
using namespace std;

int fa[1005];//并查集
int n,m;

struct node {
int u,v,w;
bool operator <(const node &t)const {//优先级
return w<t.w;
}
}edge[10005];

int find(int x){//并查集
return fa[x]==x?x:fa[x]=find(fa[x]);
}

int main()
{
while (scanf ("%d%d",&n,&m)!=EOF){
for (int i=0;i<=n;i++){//初始化
fa[i]=i;
}
int u,v,w;
for (int i=0;i<m;i++){//加边
scanf ("%d%d%d",&u,&v,&w);
edge[i]=(node){u,v,w};
}
sort(edge,edge+m);//排序
int sum=0;
int ans=0;
for (int i=0;i<m;i++){
int fu=find(edge[i].u);
int fv=find(edge[i].v);
if (fu!=fv){//不在同一个联通快则加入最小生成树
sum++;//生成树的边数加1
fa[fu]=fv;
ans+=edge[i].w;
}
if (sum==n-1)break;
}
if (sum==n-1){
printf ("%d\n\n",ans);
}else printf ("impossible\n\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: