您的位置:首页 > 其它

hdu 1213 How Many Tables 并查集

2017-07-26 21:15 429 查看
Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want
to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

Input The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M
lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

Output For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

Sample Input
2
5 3
1 2
2 3
4 5

5 1
2 5

Sample Output
2
4


#include<cstdio>
#include<cstring>
using namespace std;
int per[1010];
bool use[1010];
void init(int n)
{
for(int i=1;i<=n;i++)
per[i]=i;
}
int find(int x)
{
return x==per[x]?x:find(per[x]);
}
void unions(int a,int b)
{
int x=find(a);
int y=find(b);
if(x==y)
return ;
else
per[y]=x;
}
int main()
{
int t;
int n,m;
int x,y;
scanf("%d",&t);
while(t--)
{
scanf("%d%d",&n,&m);
init(n);
memset(use,false,sizeof(use));
for(int i=0;i<m;i++)
{
scanf("%d%d",&x,&y);
unions(x,y);
}
int ans=0;
for(int i=1;i<=n;i++)
{
if(use[find(i)]==false)
{
ans++;
use[find(i)]=true;
}
}
printf("%d\n",ans);
}
return 0;
}

题意  

输入n个人,m组朋友,若a于b是朋友,b于c值朋友,则a于c也为朋友,为朋友的人相互坐在一个桌子上。一共需要多少桌子。。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: