您的位置:首页 > 大数据 > 人工智能

2017 Multi-University Training Contest - Team 1 - 1001

2017-07-26 19:57 323 查看
[align=center][/align]

Add More Zero

[align=center]Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 761    Accepted Submission(s): 523

[/align]

[align=left]Problem Description[/align]
There is a youngster known for amateur propositions concerning several mathematical hard problems.

Nowadays, he is preparing a thought-provoking problem on a specific type of supercomputer which has ability to support calculations of integers between0
and (2m−1)
(inclusive).

As a young man born with ten fingers, he loves the powers of
10
so much, which results in his eccentricity that he always ranges integers he would like to use from1
to 10k
(inclusive).

For the sake of processing, all integers he would use possibly in this interesting problem ought to be as computable as this supercomputer could.

Given the positive integer m,
your task is to determine maximum possible integer
k
that is suitable for the specific supercomputer.
 

[align=left]Input[/align]
The input contains multiple test cases. Each test case in one line contains only one positive integerm,
satisfying 1≤m≤105.
 

[align=left]Output[/align]
For each test case, output "Case #x:y"
in one line (without quotes), where x
indicates the case number starting from 1
and y
denotes the answer of corresponding case.
 

[align=left]Sample Input[/align]

1
64

 

[align=left]Sample Output[/align]

Case #1: 0
Case #2: 19

 题目大意:给你一个数m求2的m次方-1等于10的k次方求出这个k。

题目做法:k=log10(2的m次方)即k=m*log10(2)。
#include<cstdio>
#include<cstring>
#include<iostream>
#include<cmath>
using namespace std;
int main()
{
int m;
int sum=1;
while(scanf("%d",&m)!=EOF)
{
double result;
result=log10(2.0);
int key=result*m;
printf("Case #%d: %d\n",sum,key);
sum++;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: 
相关文章推荐