您的位置:首页 > 其它

E - Max Sum HDU - 1003

2017-07-26 19:34 197 查看
Given a sequence a11,a22,a33......ann,
your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14. 

InputThe first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000). 

OutputFor each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of
the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases. 

Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5


Sample Output
Case 1:
14 1 4

Case 2:
7 1 6


题意:输出子序列的最大值;

思路:从第一个数开始计算子序列的值,若小于0,则从当前值为起点开始继续相加,实际就是为动态规划;

                初值为dp[0]=a[0],状态转移方程为dp[i]=dp[i-1]<0?dp[i-1]:dp[i-1]+a[i];

下面附上代码:
#include<bits/stdc++.h>
using namespace std;
int a[100005],dp[100005];
int main()
{
int t,n;
cin>>t;
int k=0;
while(t--)
{
cin>>n;
int max;
memset(a,0,sizeof(a));
for(int i=1;i<=n;i++)
scanf("%d",&a[i]);
dp[1]=a[1];
for(int i=2;i<=n;i++)
{
if(dp[i-1]<0) dp[i]=a[i];
else dp[i]=dp[i-1]+a[i];
}
max=dp[1];
int p=1;
for(int i=1;i<=n;i++)
{
if(max<dp[i])
{
max=dp[i];
p=i;
}
}
int h=p;
int sum=0;
for(int i=p;i>=1;i--)
{
sum+=a[i];
if(sum==max)
h=i;
}
printf("Case %d:\n",++k);
printf("%d %d %d\n",max,h,p);
if(t) printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: