您的位置:首页 > 大数据 > 人工智能

2017 Multi-University Training Contest - Team 1(hdu 6043 KazaQ's Socks)

2017-07-26 17:47 531 查看


KazaQ's Socks

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)

Total Submission(s): 642    Accepted Submission(s): 401

Problem Description

KazaQ wears socks everyday.

At the beginning, he has n pairs
of socks numbered from 1 to n in
his closets. 

Every morning, he puts on a pair of socks which has the smallest number in the closets. 

Every evening, he puts this pair of socks in the basket. If there are n-1 pairs
of socks in the basket now, lazy KazaQ has to wash them. These socks will be put in the closets again in tomorrow evening.

KazaQ would like to know which pair of socks he should wear on the k-th
day.

 

Input

The input consists of multiple test cases. (about 2000)

For each case, there is a line contains two numbers n,k (2≤n≤109,1≤k≤1018).

 

Output

For each test case, output "Case #x: y"
in one line (without quotes), where x indicates
the case number starting from 1 and y denotes
the answer of corresponding case.

 

Sample Input

3 7
3 6
4 9

 

Sample Output

Case #1: 3
Case #2: 1
Case #3: 2

题意就是KazaQ有n双袜子
a8c2
,每次穿编号最小的袜子,每双袜子穿一天,他每次穿到剩1双袜子时将穿过的n-1双洗了,问第k天KazaQ穿袜子的编号,这道题稍微找找规律就会发现他穿袜子的顺序是1,2,3,...,n,1,2,3,...n-2,n-1,1,2,3,...,n-2,n,1,2,3,...,n-2,n-1,1,2,....(n>2);
n=2是就是,1,2,1,2,1,2...
代码如下:
#include <bits/stdc++.h>
using namespace std;
int main()
{
long long n,k,t=0;
while(cin>>n>>k)
{
t++;
if(n==2)
{
cout<<"Case #"<<t<<": "<<(k+1)%2+1<<endl;
continue;
}
if(k<=n)
{
cout<<"Case #"<<t<<": "<<k<<endl;
}
else
{
if(k%(n-1)==1)
{
if(k/(n-1)%2==1)
{
cout<<"Case #"<<t<<": "<<n<<endl;
}
else
{
cout<<"Case #"<<t<<": "<<n-1<<endl;
}
}
else
{
if(k%(n-1)!=0)
{
cout<<"Case #"<<t<<": "<<k%(n-1)-1<<endl;
}
else
{
cout<<"Case #"<<t<<": "<<n-2<<endl;
}
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: 
相关文章推荐