您的位置:首页 > 其它

【多校训练】 hdu 6033 Add More Zero

2017-07-26 15:49 288 查看
Problem Description

There is a youngster known for amateur propositions concerning several mathematical hard problems.

Nowadays, he is preparing a thought-provoking problem on a specific type of supercomputer which has ability to support calculations of integers between 0 and (2m−1) (inclusive).

As a young man born with ten fingers, he loves the powers of 10 so
much, which results in his eccentricity that he always ranges integers he would like to use from 1to 10k (inclusive).

For the sake of processing, all integers he would use possibly in this interesting problem ought to be as computable as this supercomputer could.

Given the positive integer m,
your task is to determine maximum possible integer k that
is suitable for the specific supercomputer.

 

Input

The input contains multiple test cases. Each test case in one line contains only one positive integer m,
satisfying 1≤m≤105.

 

Output

For each test case, output "Case #x: y"
in one line (without quotes), where x indicates
the case number starting from 1 and y denotes
the answer of corresponding case.

 

Sample Input

1
64

 

Sample Output

Case #1: 0
Case #2: 19

答案就是 ⌊log10(2m−1)⌋⌊log​10​​(2​m​​−1)⌋,注意到不存在 10k=2m10​k​​=2​m​​ 

所以⌊log10(2m−1)⌋=⌊log102m⌋=⌊mlog102⌋⌊log​10​​(2​m​​−1)⌋=⌊log​10​​2​m​​⌋=⌊mlog​10​​2⌋,这样做的时间复杂度是
O(1) 。

//
//  main.cpp
//  1001
//
//  Created by zc on 2017/7/25.
//  Copyright © 2017年 zc. All rights reserved.
//

#include <iostream>
#include<cstdio>
#include<cmath>
using namespace std;

int main(int argc, const char * argv[]) {
int kase=0,n;
while(~scanf("%d",&n))
{
double ans=0;
ans=(double)n*log10(2);
printf("Case #%d: %d\n",++kase,(int)ans);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: