您的位置:首页 > 产品设计 > UI/UE

Windows Message Queue HDU - 1509

2017-07-26 14:58 369 查看
Message queue is the basic fundamental of windows system. For each process, the system maintains a message queue. If something happens to this process, such as mouse click, text change, the system will add a message to the queue.
Meanwhile, the process will do a loop for getting message from the queue according to the priority value if it is not empty. Note that the less priority value means the higher priority. In this problem, you are asked to simulate the message queue for putting
messages to and getting message from the message queue.

InputThere's only one test case in the input. Each line is a command, "GET" or "PUT", which means getting message or putting message. If the command is "PUT", there're one string means the message name and two integer means the parameter and priority
followed by. There will be at most 60000 command. Note that one message can appear twice or more and if two messages have the same priority, the one comes first will be processed first.(i.e., FIFO for the same priority.) Process to the end-of-file.
OutputFor each "GET" command, output the command getting from the message queue with the name and parameter in one line. If there's no message in the queue, output "EMPTY QUEUE!". There's no output for "PUT" command.
Sample Input
GET
PUT msg1 10 5
PUT msg2 10 4
GET
GET
GET


Sample Output
EMPTY QUEUE!
msg2 10
msg1 10
EMPTY QUEUE!

这个题和看病要排队那个挺像的  用优先级队列 只不过多了个参数 有相同信息的话也没关系啊符合先进先出

#include <iostream>

#include <iostream>

#include <cstdio>

#include <string.h>

#include <queue>

#include <stack>

using namespace std;

struct node

{

    int rank,num,tmp;

    char str[100];

    friend bool operator<(node a,node b)

    {

        if(a.rank==b.rank)return a.num>b.num;

        return a.rank>b.rank;

    }

};

int main()

{

    char a[10];

    priority_queue<node>q;

    int i=1;

    while(scanf("%s",a)!=-1)

    {

        node s;

        

        if(a[0]=='G')

        {

            if(q.empty())

              printf("EMPTY QUEUE!\n");

            else

            {

               s=q.top();

               q.pop();

               printf("%s %d\n",s.str,s.tmp);

            }

        }

        else

        {

            char b[100];

            int x,y;

            scanf("%s%d%d",b,&x,&y);

            s.num=i++;

            s.tmp=x;

            s.rank=y;

            strcpy(s.str,b);

            q.push(s);

        }

    }

    return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: