您的位置:首页 > 运维架构

CSU-ACM2017暑假集训2-二分搜索 poj-3258- River Hopscotch

2017-07-26 13:41 429 查看

题目:


Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end, Lunits
away from the start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting and ending rocks, N (0 ≤ N ≤ 50,000) more rocks appear, each at an integral distance Di from the start (0 < Di < L).

To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river.

Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in
order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up to M rocks (0 ≤ M ≤ N).

FJ wants to know exactly how much he can increase the shortest distance *before* he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set of M rocks.

Input
Line 1: Three space-separated integers: L, N, and M 

Lines 2.. N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position.

Output
Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removing M rocks

Sample Input
25 5 2
2
14
11
21
17


Sample Output
4


Hint
Before removing any rocks, the shortest jump was a jump of 2 from 0 (the start) to 2. After removing the rocks at 2 and 14, the shortest required jump is a jump of 4 (from 17 to 21 or from 21 to 25).
           

          题意:小牛过河,河中有n块石头,每个都给出了坐标,为了锻炼小牛的跳跃力,现在去除掉m个石头,问能让小牛跳过河的石头序列中最大的最小间隔(最大化最小值)。

         思路:二分这个所求的值,再判断这个值能不能吗满足条件,也就是能让小牛过河的n-m个石头之间的间隔是不是都大于这个二分值。

         代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>

using namespace std;

int n,c,len;
int s[55555];

int judge(int dis)
{
int l,r;
l=0;
for(int i=1;i<n-c;i++)
{
r=l+1;
while(r<n&&s[r]-s[l]<dis)
r++;
if(r==n)
return 0;
l=r;
}
return 1;
}

int bs(int l,int r)
{
while(r-l>1)
{
int m=(r-l)/2+l;
if(judge(m))
l=m;
else
r=m;
}
return  l;
}

int main()
{
while(scanf("%d%d%d",&len,&n,&c)!=EOF)
{
s[0]=0;
for(int i=1;i<=n;i++)
{
scanf("%d",&s[i]);
}
s[n+1]=len;
n+=2;
sort(s,s+n);
int ans=bs(0,s[n-1]+1);
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  acm