您的位置:首页 > 其它

HDU 6033 Add More Zero 【数学】【基础】

2017-07-26 11:52 309 查看

Add More Zero

[b]Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)

Total Submission(s): 547    Accepted Submission(s): 390
[/b]

[align=left]Problem Description[/align]
There is a youngster known for amateur propositions concerning several mathematical hard problems.

Nowadays, he is preparing a thought-provoking problem on a specific type of supercomputer which has ability to support calculations of integers between 0 and (2m−1) (inclusive).

As a young man born with ten fingers, he loves the powers of 10 so
much, which results in his eccentricity that he always ranges integers he would like to use from 1 to 10k (inclusive).

For the sake of processing, all integers he would use possibly in this interesting problem ought to be as computable as this supercomputer could.

Given the positive integer m,
your task is to determine maximum possible integer k that
is suitable for the specific supercomputer.
 

[align=left]Input[/align]
The input contains multiple test cases. Each test case in one line contains only one positive integer m,
satisfying 1≤m≤105.
 

[align=left]Output[/align]
For each test case, output "Case #x: y"
in one line (without quotes), where x indicates
the case number starting from 1 and y denotes
the answer of corresponding case.
 

[align=left]Sample Input[/align]

1
64

 

[align=left]Sample Output[/align]

Case #1: 0
Case #2: 19

 

[align=left]Source[/align]
2017
Multi-University Training Contest - Team 1
 

[align=left]Recommend[/align]
liuyiding

题目链接:

2017多校训练第一场 1001

题目大意:

用10^k表示出2^m-1,求k的整数部分

解题思路:

因为1≤m≤1e5,所以2^m的最后一位只能为2,4,8,6,因此2^m-1中的-1对它的结果不会造成影响。

令10^k = 2^m 两边取对数,得 k = m*log10(2)的整数部分。

Mycode:

#include <bits/stdc++.h>
using namespace std;
typedef long long LL;
const int MAX = 10005;
const int MOD = 1e9+7;
const int INF = 0x3f3f3f3f;

int main()
{
int m, cas = 0;
while(~scanf("%d",&m))
{
int ans = floor(m*log10(2));
printf("Case #%d: %d\n",++cas, ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: