您的位置:首页 > 其它

【POJ - 2955 Brackets】 区间DP

2017-07-26 11:50 423 查看
L - Brackets

We give the following inductive definition of a “regular brackets” sequence:

the empty sequence is a regular brackets sequence,
if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
if a and b are regular brackets sequences, then ab is a regular brackets sequence.
no other sequence is a regular brackets sequence
For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]


while the following character sequences are not:

(, ], )(, ([)], ([(]


Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such
that for indices i1, i2, …, im where 1 ≤ i1 < i2 < … < im ≤ n, ai1ai2 … aim is
a regular brackets sequence.

Given the initial sequence 
([([]])]
, the longest regular brackets subsequence is
[([])]
.

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters 
(
)
[
, and 
]
; each input test will have length between 1 and 100, inclusive.
The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input
((()))
()()()
([]])
)[)(
([][][)
end


Sample Output
6
6
4
0
6


题意:给出一个由'[' , ']' , '(' , ')' 构成的字符串,统计括号匹配的个数。

分析:一道基础的区间dp,先将dp数组初始化为0。然后遍历起点i,终点j,中间点k,要注意处理边界s[i]和s[j]是否匹配。

状态转移方程:dp[i][j] = max(dp[i][j], dp[i][k] + dp[k+1][j]);

 dp[i][j] = max(dp[i][j], dp[i+1][j-1] + 2);

代码如下:

#include <set>
#include <map>
#include <queue>
#include <cmath>
#include <vector>
#include <cctype>
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#define mod 835672545
#define INF 0x3f3f3f3f
#define LL long long
using namespace std;
const int MX = 105;
char s[MX];
int dp[MX][MX];
int main(){
while(~scanf("%s", s)){
if(s[0] == 'e') return 0;
memset(dp, 0, sizeof(dp));
int len = strlen(s);
for(int i = len-2; i >= 0; i--){
for(int j = i+1; j <= len-1; j++){
for(int k = i; k < j; k++){
dp[i][j] = max(dp[i][j], dp[i][k] + dp[k+1][j]);
if((s[i] == '(' && s[j] == ')') || (s[i] == '[' && s[j] == ']')){
dp[i][j] = max(dp[i][j], dp[i+1][j-1] + 2);
}
}
}
}
printf("%d\n", dp[0][len-1]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: