您的位置:首页 > 其它

17 多校1 Add More Zero 水题

2017-07-26 09:59 387 查看
[align=left]Problem Description[/align]
There is a youngster known for amateur propositions concerning several mathematical hard problems.

Nowadays, he is preparing a thought-provoking problem on a specific type of supercomputer which has ability to support calculations of integers between 0 and (2m−1) (inclusive).

As a young man born with ten fingers, he loves the powers of 10 so much, which results in his eccentricity that he always ranges integers he would like to use from 1 to 10k (inclusive).

For the sake of processing, all integers he would use possibly in this interesting problem ought to be as computable as this supercomputer could.

Given the positive integer m, your task is to determine maximum possible integer k that is suitable for the specific supercomputer.

[align=left]Input[/align]
The input contains multiple test cases. Each test case in one line contains only one positive integer m, satisfying 1≤m≤105.

[align=left]Output[/align]
For each test case, output "Case #x: y" in one line (without quotes), where x indicates the case number starting from 1 and y denotes the answer of corresponding case.

[align=left]Sample Input[/align]

1

64

[align=left]Sample Output[/align]

Case #1: 0
Case #2: 19

题意:给你m,得到一个数(2^m-1),问这个数最多有10的几次
题解:简单粗暴地记录log10(2),再拿m去除以它,经验算得符合结果

#include<iostream>
#include<cstdio>
#include<queue>
#include<vector>
#include<cstring>
#include<string>
#include<algorithm>
#include<map>
#include<cmath>
#include<math.h>
using namespace std;

const double p=log(10.0)/log(2.0);

int main()
{
int t=1,m;
while(~scanf("%d",&m))
{
printf("Case #%d: %d\n",t++,int(m/p));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: