您的位置:首页 > 产品设计 > UI/UE

CSU-ACM2017暑假集训2-二分搜索 C - 4 Values whose Sum is 0

2017-07-26 09:12 591 查看

C - 4 Values whose Sum is 0

The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n .


Input

The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 2 28 ) that belong respectively to A, B, C and D .


Output

For each input file, your program has to write the number quadruplets whose sum is zero.


Sample Input

6
-45 22 42 -16
-41 -27 56 30
-36 53 -37 77
-36 30 -75 -46
26 -38 -10 62
-32 -54 -6 45


Sample Output

5


Hint

Sample Explanation: Indeed, the sum of the five following quadruplets is zero: (-45, -27, 42, 30), (26, 30, -10, -46), (-32, 22, 56, -46),(-32, 30, -75, 77), (-32, -54, 56, 30).


有四个vector,每个vector的元素至多4000,挨个枚举复杂度O(n^4),肯定超时。所以vcvd 相加得到 vSum2,再遍历 vavb,当总和为零的quadruplet存在时,有以下关系:

∃x,y∈[0,n),i∈[0,vSum2.size()), 0−va[x]−vb[y]=vSum2[i]

因此可以用 quantitiy=upper_bound()−lower_bound() 在 vSum2 中统计数值为 −va[x]−vb[y] 的元素的个数(不存在时,quantity 自然为零)。

#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <vector>
#include <map>
using namespace std;
int main(){

int n;
while(cin >> n){
vector<int> va, vb, vc, vd, vSum1, vSum2;
map<int,int> myMap;
int ta, tc, tb, td;
for(int i = 0; i < n; i++){
scanf("%d%d%d%d", &ta, &tb, &tc, &td);
va.push_back(ta), vb.push_back(tb), vc.push_back(tc), vd.push_back(td);
}
for(int i = 0; i < n; i++){
for(int j = 0; j < n; j++){
vSum2.push_back(vc[j] + vd[i]);
}
}
sort(vSum2.begin(), vSum2.end());
int quantity = 0;
for(int i = 0; i < n; i++)
for(int j = 0; j < n; j++){
quantity += upper_bound(vSum2.begin(), vSum2.end(), -va[i] - vb[j]) - lower_bound(vSum2.begin(), vSum2.end(), -va[i] - vb[j]);
}
cout << quantity << endl;
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  搜索 C++ 二分