您的位置:首页 > 大数据 > 人工智能

2017 Multi-University Training Contest - Team 1 KazaQ's Socks

2017-07-26 01:00 513 查看
[align=left]Problem Description[/align]
KazaQ wears socks everyday.

At the beginning, he has n pairs of socks numbered from 1 to n in his closets.

Every morning, he puts on a pair of socks which has the smallest number in the closets.

Every evening, he puts this pair of socks in the basket. If there are n−1 pairs of socks in the basket now, lazy KazaQ has to wash them. These socks will be put in the closets again in tomorrow evening.

KazaQ would like to know which pair of socks he should wear on the k-th day.

[align=left]Input[/align]
The input consists of multiple test cases. (about 2000)

For each case, there is a line contains two numbers n,k (2≤n≤109,1≤k≤1018).

[align=left]Output[/align]
For each test case, output "Case #x: y" in one line (without quotes), where x indicates the case number starting from 1 and y denotes the answer of corresponding case.

[align=left]Sample Input[/align]

3 7

3 6

4 9

[align=left]Sample Output[/align]

Case #1: 3

Case #2: 1

Case #3: 2

题意:自己看看吧,很简单
解法:
1 理解题意后,知道应该是找循环节,于是写了1 2 3 和 1 2 3 4发现是1 2,1 3和1 2 3,1 2 4这样顺序
2 然后分情况讨论

#include<bits/stdc++.h>
typedef long long LL;
typedef unsigned long long ULL;
using namespace std;
const int maxn=2e5+10;
int main(){
long long n,k;
long long num=1;
while(cin>>n>>k){
printf("Case #%lld: ",num++);
if(k<=n){
cout<<k<<endl;
}else{
k-=n;
long long pos=k/(n-1);
long long ans=k%(n-1);
if(ans){
cout<<ans<<endl;
}else{
if(pos%2){
cout<<n-1<<endl;
}else{
cout<<n<<endl;
}
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: 
相关文章推荐