您的位置:首页 > 大数据 > 人工智能

B - Train Problem I

2017-07-25 23:28 141 查看
As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world ^v^). But here comes
a problem, there is only one railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves,
train A can't leave until train B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your
task is to determine whether the trains can get out in an order O2.

Input

    The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the
Sample Input.

Output

    The output contains a string "No." if you can't exchange O2 to O1, or you should output a line contains "Yes.", and then output your way in exchanging the order(you should output "in" for a train getting into the railway, and "out" for a train getting out
of the railway). Print a line contains "FINISH" after each test case. More details in the Sample Output.

Sample Input

    3 123 321

    3 123 312

Sample Output

    Yes.

    in

    in

    in

    out

    out

    out

    FINISH

    No.

    FINISH

            

      

    For the first Sample Input, we let train 1 get in, then train 2 and train 3.

    So now train 3 is at the top of the railway, so train 3 can leave first, then train 2 and train 1.

    In the second Sample input, we should let train 3 leave first, so we have to let train 1 get in, then train 2 and train 3.

    Now we can let train 3 leave.

    But after that we can't let train 1 leave before train 2, because train 2 is at the top of the railway at the moment.

    So we output "No.".

Hint

题意:比较第二个数列是否能由第一个通过栈的操作得到;

思路:直接模拟好了,可以用两个数组挨个比较,最后用一个数组标记来判断进出情况好了;

           如果到最后栈不为空则说明不行;

下面附上代码:

#include<cstdio>
#include<stack>
#include<algorithm>
#include<cstring>
#define max 100
using namespace std;
int main()
{
char ch1[max],ch2[max];
int rank[max];
int n;
int i,j,k;
while(~scanf("%d%s%s",&n,ch1,ch2))
{
getchar();
i=0;j=0;k=1;
stack<char> s;
s.push(ch1[0]);
rank[0]=1;
while(i<n&&j<n)
{
if(s.size()&&s.top()==ch2[j])
{
j++;
s.pop();
rank[k++]=0;
}
else
{
if(i==n) break;
s.push(ch1[++i]);
rank[k++]=1;
}
}
if(i==n) puts("No.");
else
{
puts("Yes.");
for(int m=0;m<k;m++)
{
if(rank[m]) puts("in");
else puts("out");
}
}
puts("FINISH");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: