您的位置:首页 > 其它

HDU1060 Leftmost Digit

2017-07-25 21:42 232 查看
1060

Leftmost Digit

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 18433 Accepted Submission(s): 7238

Problem Description

Given a positive integer N, you should output the leftmost digit of N^N.

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.

Each test case contains a single positive integer N(1<=N<=1,000,000,000).

Output

For each test case, you should output the leftmost digit of N^N.

Sample Input

2

3

4

Sample Output

2

2

Hint

In the first case, 3 * 3 * 3 = 27, so the leftmost digit is 2.

In the second case, 4 * 4 * 4 * 4 = 256, so the leftmost digit is 2.

Author

Ignatius.L

Recommend

We have carefully selected several similar problems for you: 1018 1071 1573 1066 1065

m=n^n,两边分别对10取对数得 log10(m)=n*log10(n),得m=10^(n*log10(n));

#include<stdio.h>
#include<math.h>
using namespace std;
int main() {
int T,n;
scanf("%d", &T);
while (T--&&scanf("%d", &n) != EOF)
{
double temp1, temp2;
temp1 = n*1.0*log10(1.0*n);
temp2 = temp1 - (__int64)(temp1);
printf("%.0lf\n", (floor)(pow(10.0, temp2)));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  hdu