您的位置:首页 > 其它

HDU 6033 Add More Zero - 2017多校联盟1 A题

2017-07-25 20:16 507 查看

Add More Zero

[b]Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
[/b]

[align=left]Problem Description[/align]
There is a youngster known for amateur propositions concerning several mathematical hard problems.

Nowadays, he is preparing a thought-provoking problem on a specific type of supercomputer which has ability to support calculations of integers between
0
and (2m−1)
(inclusive).

As a young man born with ten fingers, he loves the powers of
10
so much, which results in his eccentricity that he always ranges integers he would like to use from
1
to 10k
(inclusive).

For the sake of processing, all integers he would use possibly in this interesting problem ought to be as computable as this supercomputer could.

Given the positive integer m,
your task is to determine maximum possible integer
k
that is suitable for the specific supercomputer.
 

[align=left]Input[/align]
The input contains multiple test cases. Each test case in one line contains only one positive integer
m,
satisfying 1≤m≤105.
 

[align=left]Output[/align]
For each test case, output "Case #x:
y"
in one line (without quotes), where x
indicates the case number starting from 1
and y
denotes the answer of corresponding case.
 

[align=left]Sample Input[/align]

1
64

 

[align=left]Sample Output[/align]

Case #1: 0
Case #2: 19

 

[align=left]Source[/align]
2017 Multi-University Training Contest - Team 1

题意:
给定m,求最大的k 满足
10^k ≦ (2^m) -1

思路:

利用log公式,得到
k <=

,即 k =


取下限
由于不存在


所以



代码:
#include <iostream>
#include <cstdio>
#include <cmath>
using namespace std;

int main()
{
int m;
double res = log10(2);
int i = 1;
while(scanf("%d",&m)!=EOF){
int ans = (int)m*res;
printf("Case #%d: %d\n",i,ans);
i++;
}
return 0;
}


 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  hdu ACM 数学题