您的位置:首页 > 其它

POJ - 2386 Lake Counting (DFS)

2017-07-25 19:57 417 查看
Lake Counting

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 36172 Accepted: 17965
Description

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure
out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors. 

Given a diagram of Farmer John's field, determine how many ponds he has.
Input

* Line 1: Two space-separated integers: N and M 

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.
Output

* Line 1: The number of ponds in Farmer John's field.
Sample Input
10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output
3


题意:n*m的院子里有水(W),水只要八方有水就算连着,求院子里的水洼数量。

解决:DFS八个方向

细节:

#include<iostream>
#include<algorithm>
using namespace std;

int n , m, num = 0;
char a[110][110];

void dfs(int x, int y){
a[x][y] = '.';

for(int i = -1; i <= 1; i++)
for(int j = -1; j <= 1; j++){
int nx = x + i, ny = y + j;
if(0 <= nx && 0 <= ny && nx <= n && ny <= m && a[nx][ny] == 'W')
dfs(nx, ny);
}

return;
}

int main(){
cin >> n >> m;
for(int i = 0; i < n; i++)
cin >> a[i];
for(int i = 0; i < n; i++)
for(int j = 0; j < m; j++){
if(a[i][j]=='W'){
dfs(i, j);
num++;
}
}
cout << num << endl;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: