您的位置:首页 > 大数据 > 人工智能

HDU6043 & 2017 Multi-University Training Contest - Team 1

2017-07-25 19:44 417 查看

KazaQ’s Socks

Problem Description

KazaQ wears socks everyday.

At the beginning, he has n pairs of socks numbered from 1 to n in his closets.

Every morning, he puts on a pair of socks which has the smallest number in the closets.

Every evening, he puts this pair of socks in the basket. If there are n−1 pairs of socks in the basket now, lazy KazaQ has to wash them. These socks will be put in the closets again in tomorrow evening.

KazaQ would like to know which pair of socks he should wear on the k-th day.

Input

The input consists of multiple test cases. (about 2000)

For each case, there is a line contains two numbers n,k (2≤n≤109,1≤k≤1018).

Output

For each test case, output “Case #x: y” in one line (without quotes), where x indicates the case number starting from 1 and y denotes the answer of corresponding case.

Sample Input

3 7

3 6

4 9

Sample Output

Case #1: 3

Case #2: 1

Case #3: 2

找找规律就出来了

#include<bits/stdc++.h>
using namespace std;
using LL=int64_t;

int main()
{
ios::sync_with_stdio(0);
cin.tie(0);
LL n,k;
int kase=1;
while(cin>>n>>k) {
cout<<"Case #"<<kase++<<": ";
if(k<=n) cout<<k<<endl;
else {
int sum=(k-n)%(2*n-2);
if(sum<=(n-1)) {
if(sum!=0)cout<<sum<<endl;
else cout<<n<<endl;
}
else {
if(sum==2*n-2) cout<<n<<endl;
else cout<<sum-(n-1)<<endl;
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: 
相关文章推荐