您的位置:首页 > 其它

杭电暑期多校集训—KazaQ's Socks

2017-07-25 19:03 399 查看


KazaQ's Socks

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)

Total Submission(s): 0    Accepted Submission(s): 0


Problem Description

KazaQ wears socks everyday.

At the beginning, he has n pairs
of socks numbered from 1 to n in
his closets. 

Every morning, he puts on a pair of socks which has the smallest number in the closets. 

Every evening, he puts this pair of socks in the basket. If there are n−1 pairs
of socks in the basket now, lazy KazaQ has to wash them. These socks will be put in the closets again in tomorrow evening.

KazaQ would like to know which pair of socks he should wear on the k-th
day.

 

Input

The input consists of multiple test cases. (about 2000)

For each case, there is a line contains two numbers n,k (2≤n≤109,1≤k≤1018).

 

Output

For each test case, output "Case #x: y"
in one line (without quotes), where x indicates
the case number starting from 1 and y denotes
the answer of corresponding case.

 

Sample Input

3 7
3 6
4 9

 

Sample Output

Case #1: 3
Case #2: 1
Case #3: 2
题意:KazaQ有n双袜子,放在柜子里,每天从柜子拿一双穿,穿过的放在篮子里,当篮子里达到n-1双就洗一次,洗过的第二天晚上再放进柜子里,问第k天穿哪双袜子。这是一道规律题,了解题意就很容易找到规律。
#include<iostream>
using namespace std;
int main()
{
long long int a,b,c,d,e;
a=0;
while(cin>>b>>c)
{
a++;
if(c<=b)
{
cout<<"Case #"<<a<<": "<<c<<endl;
continue;
}
c=c-b;
d=int(c/(b-1));
e=c%(b-1);
if(e==0)
{
if(d%2==0)
cout<<"Case #"<<a<<": "<<b<<endl;
else
cout<<"Case #"<<a<<": "<<b-1<<endl;
}
else
cout<<"Case #"<<a<<": "<<e<<endl;
}
return 0;
}



                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: