您的位置:首页 > 其它

HDU 2017多校联赛-1011 KazaQ's Socks

2017-07-25 18:07 393 查看

Problem Description

KazaQ wears socks everyday.

At the beginning, he has n pairs of socks numbered from 1 to n in his closets.

Every morning, he puts on a pair of socks which has the smallest number in the closets.

Every evening, he puts this pair of socks in the basket. If there are n−1 pairs of socks in the basket now, lazy KazaQ has to wash them. These socks will be put in the closets again in tomorrow evening.

KazaQ would like to know which pair of socks he should wear on the k-th day.

Input

The input consists of multiple test cases. (about 2000)

For each case, there is a line contains two numbers n,k (2≤n≤109,1≤k≤1018).

Output

For each test case, output “Case #x: y” in one line (without quotes), where x indicates the case number starting from 1 and y denotes the answer of corresponding case.

Sample Input

3 7

3 6

4 9

Sample Output

Case #1: 3

Case #2: 1

Case #3: 2

水水水

#include<iostream>
using namespace std;
int main()
{
long long int a,b,c,d,e;
a=0;
while(cin>>b>>c)
{
a++;
if(c<=b)
{
cout<<"Case #"<<a<<": "<<c<<endl;
continue;
}
c=c-b;
d=int(c/(b-1));
e=c%(b-1);
if(e==0)
{
if(d%2==0)
cout<<"Case #"<<a<<": "<<b<<endl;
else
cout<<"Case #"<<a<<": "<<b-1<<endl;
}
else
cout<<"Case #"<<a<<": "<<e<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: