您的位置:首页 > 其它

算法训练 2的次幂表示

2017-07-25 18:05 225 查看
问题描述
  任何一个正整数都可以用2进制表示,例如:137的2进制表示为10001001。

  将这种2进制表示写成2的次幂的和的形式,令次幂高的排在前面,可得到如下表达式:137=2^7 2^3 2^0

  现在约定幂次用括号来表示,即a^b表示为a(b)

  此时,137可表示为:2(7) 2(3) 2(0)

  进一步:7=2^2 2 2^0 (2^1用2表示)

  3=2 2^0 

  所以最后137可表示为:2(2(2) 2 2(0)) 2(2 2(0)) 2(0)

  又如:1315=2^10 2^8 2^5 2 1

  所以1315最后可表示为:

  2(2(2 2(0)) 2) 2(2(2 2(0))) 2(2(2) 2(0)) 2 2(0)

输入格式
  正整数(1<=n<=20000)

输出格式
  符合约定的n的0,2表示(在表示中不能有空格)

样例输入
137

样例输出
2(2(2) 2 2(0))2(2 2(0)) 2(0)

样例输入
1315

样例输出
2(2(2 2(0)) 2)2(2(2 2(0))) 2(2(2) 2(0)) 2 2(0)

提示
  用递归实现会比较简单,可以一边递归一边输出

import java.util.Scanner;

public class Main {
public static void main(String[] args){
// TODO Auto-generated methodstub
Scanner sc=new Scanner(System.in);
int n=sc.nextInt();
fun(n);
}
public static void fun(int n){
int count=0;
int num=0;
int temp=0;
int[] a=new int[20];
while(n!=0){
temp=n%2;
if(temp==1){
a[num ]=count;
}
count ;
n=n/2;
}
for(int i=num-1;i>=0;i--){
if(a[i]==0){
System.out.print("2(0)");
}else if(a[i]==1){
System.out.print("2");
}else{
System.out.print("2(");
fun(a[i]);
System.out.print(")");
}
if(i!=0){
System.out.print(" ");}
}
}
}


注:代码小编测试过了,可直接复制使用,,喜欢请关注,小编持续更新,,,
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: