您的位置:首页 > 其它

2017杭电多校联赛 1001 Add More Zero(取对数)HDU 6033

2017-07-25 17:35 573 查看


Add More Zero

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)

Total Submission(s): 0    Accepted Submission(s): 0


Problem Description

There is a youngster known for amateur propositions concerning several mathematical hard problems.

Nowadays, he is preparing a thought-provoking problem on a specific type of supercomputer which has ability to support calculations of integers between 0 and (2m−1) (inclusive).

As a young man born with ten fingers, he loves the powers of 10 so
much, which results in his eccentricity that he always ranges integers he would like to use from1 to 10k (inclusive).

For the sake of processing, all integers he would use possibly in this interesting problem ought to be as computable as this supercomputer could.

Given the positive integer m,
your task is to determine maximum possible integer k that
is suitable for the specific supercomputer.

 

Input

The input contains multiple test cases. Each test case in one line contains only one positive integer m,
satisfying 1≤m≤105.

 

Output

For each test case, output "Case #x: y"
in one line (without quotes), where x indicates
the case number starting from 1 and y denotes
the answer of corresponding case.

 

Sample Input

1
64

 

Sample Output

Case #1: 0
Case #2: 19
题目大意:求比2^m - 1小的的10^k的最大的K值解题思路:其实就是求2^m-1的位数减去1因为2^m的尾数最小都是2,所以2^m-1不会改变它的位数两边取对数就可以了ln(10^k)=ln(2^m)k=ln(2)*mAC代码
#include <cstdio>
#include <iostream>
#include <cmath>
using namespace std;
int main()
{
int m, k;
int t=0;
while(~scanf("%d", &m))
{
t++;
if(m == 1) k = 0;
else k = log10(2)*m;
printf("Case #%d: %d\n",t, k);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  杭电 2017多校联赛