您的位置:首页 > 其它

HDU-多校训练赛-Add More Zero

2017-07-25 17:10 441 查看


Add More Zero

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)

Total Submission(s): 0    Accepted Submission(s): 0


Problem Description

There is a youngster known for amateur propositions concerning several mathematical hard problems.

Nowadays, he is preparing a thought-provoking problem on a specific type of supercomputer which has ability to support calculations of integers between 0 and (2m−1) (inclusive).

As a young man born with ten fingers, he loves the powers of 10 so
much, which results in his eccentricity that he always ranges integers he would like to use from 1to 
 (inclusive).

For the sake of processing, all integers he would use possibly in this interesting problem ought to be as computable as this supercomputer could.

Given the positive integer m,
your task is to determine maximum possible integer k that
is suitable for the specific supercomputer.

 

Input

The input contains multiple test cases. Each test case in one line contains only one positive integer m,
satisfying 1≤m≤105.

 

Output

For each test case, output "Case #x: y"
in one line (without quotes), where x indicates
the case number starting from 1 and y denotes
the answer of corresponding case.

 

Sample Input

1
64

 

Sample Output

Case #1: 0
Case #2: 19

10k

计算2m−1的位数
 可以看成m位的2进制换成10进制的位数,,

2m−1

一个无符号的n位二进制,其最大值为 2^n -1, 由于 2^3 =8 < 10, 2^4=16>10, 所以这个n位无符号二进制对应的十进制位数必然大于等于 (n/4) 且小于等于 (n/3)。其实这就是一个求”以2为底10的对数“的问题,

程序如下
10k
#include<cstdio>
#include<cmath>
using namespace std;
int main()
{
int a;
int t=0;
while(~scanf("%d",&a)){
t++;
int ans=(int)(a/log2(10));
printf("Case #%d: %d\n",t,ans);
}
}

2m−1
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: