您的位置:首页 > 其它

Team 1——Add More Zero

2017-07-25 17:05 267 查看
/*

Problem Description

There is a youngster known for amateur propositions concerning several mathematical hard problems.

Nowadays, he is preparing a thought-provoking problem on a specific type of supercomputer which has ability to support calculations of integers between 0 and (2m?1) (inclusive).

As a young man born with ten fingers, he loves the powers of 10 so much, which results in his eccentricity that he always ranges integers he would like to use from 1 to 10k (inclusive).

For the sake of processing, all integers he would use possibly in this interesting problem ought to be as computable as this supercomputer could.

Given the positive integer m, your task is to determine maximum possible integer k that is suitable for the specific supercomputer.

 

Input

The input contains multiple test cases. Each test case in one line contains only one positive integer m, satisfying 1≤m≤105.

 

Output

For each test case, output "Case #x: y" in one line (without quotes), where x indicates the case number starting from 1 and y denotes the answer of corresponding case.

 

Sample Input

1

64

 

Sample Output

Case #1: 0

Case #2: 19

*/

考数学知识的水题,看得懂就简单,不懂就难。
知识点1:取对数求位数。

知识点2:对数的性质。

#include<iostream>

#include<cmath>

using namespace std;

/*

*用公式k=log10 (2) * m就可以求出,其中m是2的指数,k是要求的位数

*/

int main()

{

    int  m = 0;

    int kase = 0;

    double s = log10(2);

    while (cin >> m && m) {

        double sum = m* s;

        cout << "Case #" << ++kase << ": " << (int)sum << endl;

    }

    return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  杭电多校