您的位置:首页 > 其它

杭电 Add More Zero

2017-07-25 13:35 363 查看
[align=left]Problem Description[/align]
There is a youngster known for amateur propositions concerning several mathematical hard problems.

Nowadays, he is preparing a thought-provoking problem on a specific type of supercomputer which has ability to support calculations of integers between
0
and (2m−1)
(inclusive).

As a young man born with ten fingers, he loves the powers of
10
so much, which results in his eccentricity that he always ranges integers he would like to use from
1
to 10k
(inclusive).

For the sake of processing, all integers he would use possibly in this interesting problem ought to be as computable as this supercomputer could.

Given the positive integer m,
your task is to determine maximum possible integer
k
that is suitable for the specific supercomputer.
 

[align=left]Input[/align]
The input contains multiple test cases. Each test case in one line contains only one positive integer
m,
satisfying 1≤m≤105.
 

[align=left]Output[/align]
For each test case, output "Case #x:
y"
in one line (without quotes), where x
indicates the case number starting from 1
and y
denotes the answer of corresponding case.
 

[align=left]Sample Input[/align]

1
64

 

[align=left]Sample Output[/align]

Case #1: 0
Case #2: 19

题意:输入一个数m,求0到2^m-1范围内,使得10^k最大,求k

思路:10^k<=2^m-1 10^k<2^m 取对数 log10^k<log2^m k<m*log2/log10 k<m*log10(2)

AC代码如下:
#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
using namespace std;
const double maxi=0.30102999566398;//log10(2)

int main()
{
int num=1;
int m;
while(scanf("%d",&m)!=EOF)
{
printf("Case #%d: ",num);
num++;
double ans=m*maxi;
cout<<(int)ans<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: