您的位置:首页 > 其它

POJ - 1703 Find them, Catch them (简易版种类并查集)

2017-07-25 10:59 411 查看
The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to.
The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.) 

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds: 

1. D [a] [b] 

where [a] and [b] are the numbers of two criminals, and they belong to different gangs. 

2. A [a] [b] 

where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang. 

Input
The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message
as described above.

Output
For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."

Sample Input
1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4


Sample Output
Not sure yet.
In different gangs.
In the same gang.


当x时y的父亲时x与y的关系是,y.re=x.re+1,y的父亲和x的父亲的关系是  2-y.re+1+x.re=y->x;

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<vector>
#include<cmath>
//#include <bits/stdc++.h>
using namespace std;
const int N = 1e5+7;
typedef long long LL;
int vis[1010], f
;
vector<int>G
;
struct node
{
int f, relation;
}p
;
int get(int x)
{
if(p[x].f==x) return x;
int t=p[x].f;
p[x].f=get(p[x].f);
p[x].relation=(p[t].relation+p[x].relation)%2;
return p[x].f;
}
int n, m;
void init()
{
for(int i=0;i<N;i++) p[i].f=i,p[i].relation=0;
return ;
}
void unio(int x, int y)
{
if(x>y) swap(x,y);
int a=get(x),b=get(y);
if(a!=b) f[a]=b;
return ;
}
char str
;

int main()
{
int t;
scanf("%d", &t);
while(t--)
{
scanf("%d %d", &n, &m);
init();
char str[10];
int flag=0;
while(m--)
{
scanf("%s",str);
int x, y;
scanf("%d %d", &x, &y);
if(str[0]=='A')
{
int a=get(x),b=get(y);
if(a!=b) puts("Not sure yet.");
else
{
if(p[x].relation==p[y].relation) puts("In the same gang.");
else puts("In different gangs.");
}
}
else
{
if(x>y) swap(x,y);
int a=get(x),b=get(y);
p[b].f=a;
p[b].relation=(2-p[y].relation+p[x].relation+1)%2;
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: