您的位置:首页 > 其它

HDU - 5170 GTY's math problem

2017-07-25 09:45 369 查看

GTY's math problem

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 2230    Accepted Submission(s): 863


[align=left]Problem Description[/align]
GTY is a GodBull who will get an Au in NOI . To have more time to learn algorithm knowledge, he never does his math homework. His math teacher is very unhappy for that, but she can't do anything because GTY can always get a good mark
in math exams. One day, the math teacher asked GTY to answer a question. There are four numbers on the blackboard -
a,b,c,d.
The math teacher wants GTY to compare ab
with cd.
Because GTY never does his homework, he can't figure out this problem! If GTY can't answer this question correctly, he will have to do his homework. So help him!
 

[align=left]Input[/align]
Multi test cases (about 5000). Every case contains four integers a,b,c,d(1≤a,b,c,d≤1000)separated
by spaces. Please process to the end of file.
 

[align=left]Output[/align]
For each case , if ab>cd
, print '>'. if ab<cd
, print '<'. if ab=cd
, print '='.
 

[align=left]Sample Input[/align]

2 1 1 2
2 4 4 2
10 10 9 11

 

[align=left]Sample Output[/align]

>
=
<因为a^b和c^d可能非常大,所以不能直接比较,对两边同时取对数,变为blog(a)和dlog(c)然后再比较,注意相等时的精度
AC代码:
#include<cstdio>
#include<cmath>

int main(){
double a,b,c,d,s1,s2,q=1e-12;
while(scanf("%lf%lf%lf%lf",&a,&b,&c,&d)!=EOF){
s1=b*log(a);
s2=d*log(c);
if(fabs(s1-s2)<q){
printf("=\n");
}
else if(s1>s2){
printf(">\n");
}
else if(s1<s2){
printf("<\n");
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: