您的位置:首页 > 其它

hdu--1213 How Many Tables(并查集)

2017-07-25 00:30 387 查看
[align=left]题目:hdu--1213[/align]
[align=left]
[/align]
[align=left]Problem Description:[/align]
      Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the
friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

[align=left]Input[/align]
    The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the
friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases
[align=left]
[/align]
[align=left]Output[/align]
[align=left]      For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
[/align]
[align=left]Sample Input[/align]

2
5 3
1 2
2 3
4 5
5 1
2 5

[align=left]Sample Output[/align]

2
4

[align=left]具体思路:使用并查集,再统计根节点数,输出即可,[/align]
[align=left]注意:输入几组时,中间有一行空格。
[/align]
[align=left]代码如下:[/align]
#include<iostream>
using namespace std;
const int N = 1010;
int pre
;

int find(int x){
if(x!=pre[x]){
pre[x]=find(pre[x]);
}
return pre[x];
}

void mix(int a,int b){
int fx=find(a);
int fy=find(b);
if(fx!=fy){
pre[fx]=fy;
}
}

void bcj(int n,int m){
for(int i=1;i<=n;i++){
pre[i]=i;
}
while(m--){
int a,b;
cin>>a>>b;
mix(a,b);
}
}

int main(){
int t,n,m,count;
cin>>t;
for(int i=0;i<t;i++){
cin>>n>>m;
bcj(n,m);
count=0;
if(i<t-1) getchar();getchar();
for(int j=1;j<=n;j++){
if(pre[j]==j) count++;
}
cout<<count<<endl;
}

}

[align=left]
[/align]

[align=left]PS:第一次写博客文章,其中,还有许多不足之处。[/align]
[align=left]
[/align]
[align=left]
[/align]
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  ACM 杭电 并查集