您的位置:首页 > 其它

[ACM] POJ 1068 Parencodings(模拟)

2017-07-24 20:11 225 查看
Parencodings

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 19352Accepted: 11675
Description

Let S = s1 s2...s2n be a well-formed string of parentheses. S can be encoded in two different ways:

q By an integer sequence P = p1 p2...pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence).

q By an integer sequence W = w1 w2...wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence).

Following is an example of the above encodings:

S		(((()()())))

P-sequence	    4 5 6666

W-sequence	    1 1 1456


Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string.

Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed
string. It contains n positive integers, separated with blanks, representing the P-sequence.
Output

The output file consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.
Sample Input

2
6
4 5 6 6 6 6
9
4 6 6 6 6 8 9 9 9

Sample Output

1 1 1 4 5 6
1 1 2 4 5 1 1 3 9

Source

Tehran 2001

解题思路:
题意为给一个仅仅包括括号的字符串加密有两种方法:

方法一:用p数组表示。p[i]为第i个右括号左边一共同拥有多少左括号

方法二:用w数组表示。w[i]表示当第i个括号左右匹配时,一共包含多少右括号

要求给定加密后的p数组,求出w数组。

能够依据给的p数组先求出字符串s, p[i]-p[i-1]为第i个右括号紧跟在它前面的有多少个左括号。求出s

遍历s,每次找到右括号,然后回溯,遇到右括号就计数(回溯前找到的那个也算)。直到遇到与它匹配的左括号(vis[]=0),由于一个右括号有唯一的左括号匹配,所以一旦找到它的左括号,就用vis[]=1标记下。

代码:

#include <iostream>
#include <string.h>
#include <algorithm>
using namespace std;

int p[20],w[20];
bool vis[40];//注意范围,题目中n<=20是n对括号,不是单个括号的个数.

int main()
{
int t;cin>>t;
int n;
while(t--)
{
string s;
cin>>n;
for(int i=1;i<=n;i++)
cin>>p[i];
p[0]=0;
for(int i=1;i<=n;i++)//构造s串
{
for(int j=1;j<=(p[i]-p[i-1]);j++)
s+="(";
s+=")";
}
int k=1;
memset(vis,0,sizeof(vis));
for(int i=0;i<2*n;i++)
{
int cnt=1;
if(s[i]==')')//遇到右括号
{
for(int j=i-1;j>=0;j--)//回溯
{
if(s[j]==')')
cnt++;
if(s[j]=='('&&!vis[j])//和小括号匹配
{
vis[j]=1;
break;
}
}
w[k++]=cnt;
}
}
for(int i=1;i<=n;i++)
cout<<w[i]<<" ";
cout<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: