您的位置:首页 > 其它

HDU - 1213 How Many Tables (并查集)

2017-07-24 18:42 351 查看
题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1213点击打开链接


How Many Tables

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 31871    Accepted Submission(s): 15854


Problem Description

Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

 

Input

The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines
follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

 

Output

For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

 

Sample Input

2
5 3
1 2
2 3
4 5

5 1
2 5

 

Sample Output

2
4

 

Author

Ignatius.L

 

Source

杭电ACM省赛集训队选拔赛之热身赛

 

Recommend

Eddy
基本并查集使用 不多说了 模板题

#include <iostream>
#include <queue>
#include <stdio.h>
#include <stdlib.h>
#include <stack>
#include <limits>
#include <string>
#include <string.h>
#include <vector>
#include <set>
#include <map>
#include <algorithm>
#include <math.h>
using namespace std;
int pre[1111];
int findx(int x)
{
int r=x;
while(pre[r]!=r)
{
r=pre[r];
}
int i=x;int j;
while(pre[i]!=r)
{
j=pre[i];
pre[i]=r;
i=j;
}
return r;
}
void join (int x,int y)
{
int p1=findx(x);
int p2=findx(y);
if(p1!=p2)
{
pre[p2]=p1;
}
}
int ans[1111];
int main()
{
int t=0;
scanf("%d",&t);
for(int i=0;i<t;i++)
{
memset(ans,0,sizeof(ans));
int n=0;int k=0;
scanf("%d%d",&n,&k);
for(int i=1;i<=n;i++)
pre[i]=i;
for(int i=0;i<k;i++)
{
int x;int y;
scanf("%d%d",&x,&y);
join(x,y);
}
for(int i=1;i<=n;i++)
{
ans[findx(i)]++;
}
int sum=0;
for(int i=1;i<=n;i++)
{
if(ans[i])
sum++;
}
cout <<sum << endl;
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: