您的位置:首页 > 其它

UVa 10935 - Throwing cards away I

2017-07-24 10:32 387 查看
I Given is an ordered deck of n cards numbered 1 to n with card 1 at the top and card n at the bottom. The following operation is performed as long as there are at least two cards in the deck: Throw away the top card
and move the card that is now on the top of the deck to the bottom of the deck. Your task is to find the sequence of discarded cards and the last, remaining card.

Input

Each line of input (except the last) contains a number n ≤ 50. The last line contains ‘0’ and this line should not be processed.

Output

For each number from the input produce two lines of output. The first line presents the sequence of discarded cards, the second line reports the last remaining card. No line will have leading or trailing spaces. See
the sample for the expected format.

Sample Input

7

19

10

6

0

Sample Output

Discarded cards: 1, 3, 5, 7, 4, 2

Remaining card: 6 Discarded cards: 1, 3, 5, 7, 9, 11, 13, 15, 17, 19, 4, 8, 12, 16, 2, 10, 18, 14

Remaining card: 6 Discarded cards: 1, 3, 5, 7, 9, 2, 6, 10, 8

Remaining card: 4 Discarded cards: 1, 3, 5, 2, 6

Remaining card: 4

题解:很显然这是约瑟夫环问题,用队列来做就简单多了,每次抽两张卡片,第一张踢出队列另一张加入队列尾部,一直循环直至只有一个元素为止。

#include <bits/stdc++.h>
using namespace std;
int main ()
{
int n,a,b;
while(cin>>n&&n)
{
queue<int>q;
for (int i=1; i<=n; i++)  //将所有数字入队
q.push(i);
if(n==1) //控制格式
printf("Discarded cards:\n");
else
printf("Discarded cards: ");
while(!q.empty())
{
a=q.front();
if(q.size()==1) //只有一个元素就跳出
break;
if(q.size()!=2)//控制格式
printf("%d, ",a);
else
printf("%d\n",a);
q.pop();
b=q.front();
q.pop();
q.push(b); //将第二数加入队尾
}
printf("Remaining card: %d\n",a);
}
return 0;
}



题目链接:https://vjudge.net/contest/169852#problem/C
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  STL 队列 约瑟夫环 uva