您的位置:首页 > 其它

AYIT2017暑假集训第二周周三赛 D - Meteor Shower POJ - 3669

2017-07-24 08:05 232 查看
Bessie hears that an extraordinary meteor shower is coming; reports say that these meteors will crash into earth and destroy anything they hit. Anxious for her safety, she vows to find her way to a safe location (one that is never destroyed by a meteor)
. She is currently grazing at the origin in the coordinate plane and wants to move to a new, safer location while avoiding being destroyed by meteors along her way.

The reports say that M meteors (1 ≤ M ≤ 50,000) will strike, with meteor i will striking point (Xi, Yi) (0 ≤ Xi ≤ 300; 0 ≤ Yi ≤ 300) at time Ti (0
≤ Ti  ≤ 1,000). Each meteor destroys the point that it strikes and also the four rectilinearly adjacent lattice points.

Bessie leaves the origin at time 0 and can travel in the first quadrant and parallel to the axes at the rate of one distance unit per second to any of the (often 4) adjacent rectilinear points that are not yet destroyed by a meteor. She cannot be located
on a point at any time greater than or equal to the time it is destroyed).

Determine the minimum time it takes Bessie to get to a safe place.

Input

* Line 1: A single integer: M

* Lines 2..M+1: Line i+1 contains three space-separated integers: Xi,Yi, and Ti

Output

* Line 1: The minimum time it takes Bessie to get to a safe place or -1 if it is impossible.

Sample Input
4
0 0 2
2 1 2
1 1 2
0 3 5


Sample Output
5
题目大概意思就是给你坐标和时间,在时间过后那个地点会遭到轰炸,轰炸过后那个点和他四周的四个点都不能走了,问能否找到一个安全点。如果能的话输出步数,不能输出-1.
#include<stdio.h>
#include<string.h>
#include<queue>
#include<algorithm>
using namespace std;
int vis[330][330];//存储地图
int next[5][2]= {{0,0},{1,0},{0,1},{-1,0},{0,-1}};//在主函数中因为要把自身的坐标也变化所以加了0,0.
struct note
{
int x,y,t;
} l[30000];//模拟队列
int bfs()
{
if(vis[0][0]==0) return -1;//若第一个点时间直接为0,说明直接死了;
else if(vis[0][0]==-1) return 0;//若第一个点为-1,说明他一个就是安全点
int head=1,tail=2;
l[head].x=0;//起始点坐标
l[head].y=0;
l[head].t=0;//把时间置为0
while(head<tail)
{
for(int i=1; i<5; i++)
{
int tx=l[head].x+next[i][0];
int ty=l[head].y+next[i][1];//向四个方向进行搜索
if(tx<0 || ty<0) continue;
if(vis[tx][ty]==-1) return (l[head].t+1);//若找到了vis为-1得点,说明找到了安全点
if((l[head].t+1)>=vis[tx][ty]) continue;//如果时间大于vis点的值,说明该点之前被轰炸过不能走
vis[tx][ty]=0;//走过之后把点标记为0.
l[tail].x=tx;
l[tail].y=ty;
l[tail].t=l[head].t+1;//时间加一
tail++;
}
head++;
}
return -1;
}

int main()
{
int m,k,t,x,y,x1,y1;
scanf("%d",&m);
memset(vis,-1,sizeof(vis));
for(int j=0;j<m;j++)
{
scanf("%d%d%d",&x,&y,&t);
for(int i=0; i<=4; i++)
{
x1=x+next[i][0];//输入点坐标进行计算,因为被轰炸过所以不能走
y1=y+next[i][1];
if(x1<0 || y1<0) continue;
if(vis[x1][y1]==-1)//假如是安全点把他vis值改变
vis[x1][y1]=t;
else
vis[x1][y1]=min(vis[x1][y1],t);//如果有更小的进行更新,限制路径
}
}
printf("%d\n",bfs());
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: