您的位置:首页 > 其它

POJ-2251 Dungeon Master(简单的三维bfs)

2017-07-23 21:42 176 查看
Dungeon Master

Time Limit: 1000MS

Memory Limit: 65536K

Total Submissions: 35507

Accepted: 13545

Description
You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You
cannot move diagonally and the maze is surrounded by solid rock on all sides.

Is an escape possible? If yes, how long will it take?

Input
The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size).

L is the number of levels making up the dungeon.

R and C are the number of rows and columns making up the plan of each level.

Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a '#' and empty cells are represented by a '.'. Your starting position is indicated by 'S' and the
exit by the letter 'E'. There's a single blank line after each level. Input is terminated by three zeroes for L, R and C.

Output
Each maze generates one line of output. If it is possible to reach the exit, print a line of the form

Escaped in x minute(s).

where x is replaced by the shortest time it takes to escape.

If it is not possible to escape, print the line

Trapped!

Sample Input
3 4 5S.....###..##..###.#############.####...###########.#######E1 3 3S###E####0 0 0
Sample Output
Escaped in 11 minute(s).Trapped!
Source
Ulm Local 1997
分析:二维bfs大家应该都会,把4个方向改成6个方向就可以了,注意的是走迷宫最后的时候那个E的处理。

#include <iostream>
#include<stdio.h>
#include<queue>
#include<string.h>

using namespace std;

const int SIZE=35;
int l,r,c;

char mp[SIZE][SIZE][SIZE];
int step[SIZE][SIZE][SIZE];
int check[SIZE][SIZE][SIZE];

int to[6][3]={{0,0,1},{0,0,-1},{0,1,0},{0,-1,0},{1,0,0},{-1,0,0}};
struct node
{
int i,j,k;
node(int a,int b,int c)
{
i=a;j=b;k=c;
}
};

void bfs(int r1,int r2,int r3,int e1,int e2,int e3)
{
queue<node> q;
while(!q.empty
4000
())
{
q.pop();
}
q.push(node(r1,r2,r3));
check[r1][r2][r3]=1;
step[r1][r2][r3]=0;

while(!q.empty())
{
int n1=q.front().i;
int n2=q.front().j;
int n3=q.front().k;
q.pop();

if(n1==e1 && n2==e2 &&n3==e3) break;

for(int i=0;i<6;i++)
{
int new1=n1+to[i][0];
int new2=n2+to[i][1];
int new3=n3+to[i][2];

if(new1>=0 && new1<l &&new2>=0 && new2<r &&new3>=0 && new3<c &&mp[new1][new2][new3]=='.'&&(!check[new1][new2][new3]))
{

check[new1][new2][new3]=1;
step[new1][new2][new3]=step[n1][n2][n3]+1;
q.push(node(new1,new2,new3));
}
}
}
}

int main()
{

int r1,r2,r3;
int e1,e2,e3;

while(cin>>l>>r>>c &&(l||r||c))
{
memset(mp,0,sizeof(mp));
memset(step,0,sizeof(step));
memset(check,0,sizeof(check));
for(int i=0;i<l;i++,getchar())
{
for(int j=0;j<r;j++,getchar())
{
for(int k=0;k<c;k++)
{
cin>>mp[i][j][k];
if(mp[i][j][k]=='S')
{
r1=i;r2=j;r3=k;
}
if(mp[i][j][k]=='E')
{
e1=i;e2=j;e3=k;mp[i][j][k]='.';//这个地方把最后的E改成.不然最后一步搜不到。
}
}
}

}
bfs(r1,r2,r3,e1,e2,e3);
if(step[e1][e2][e3])
{
printf("Escaped in %d minute(s).\n",step[e1][e2][e3]);
}
else
{
puts("Trapped!");
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: